[solved] Mailer Error: Language string failed to load

Solutions for other advanced phplisters

[solved] Mailer Error: Language string failed to load

Postby DGibson111 » 11:25pm, Wed 07 Nov, 2007

Hello there,

I need some help with smtp. My configuration doesn't seem to want to work with sending mail. When I subscribe I get the following error on the subscibe page:

Sorry, sending the email to request your confirmation failed, please click "Reload" to try again. If it still does not work, it may be because you are listed on our "Black List", which means that you cannot receive emails from our newsletter system. In that case, please contact the administrator.

When I look at the event log the following error is logged:

Mailer Error: Language string failed to load: connect_host

I then try to "send a message" (at test msg). It fails and the event logs give me this error:
Mailer Error: SMTP Error: Could not connect to SMTP host

I have configured my config.php file smtp lines as follows:

# To use a SMTP please give your server hostname here, leave it blank to use the standard
# PHP mail() command.
define("PHPMAILERHOST",'smtpout.secureserver. net');

# if you want to use smtp authentication when sending the email uncomment the following
# two lines and set the username and password to be the correct ones
#$phpmailer_smtpuser = 'userATmydomain';
#$phpmailer_smtppassword = 'psswd';

$phpmailer_smtpport = '80'


I have tried uncommenting the $phpmailer_smtpuser and smtppassword lines but this doesn't seem to make a difference.

Any suggestions are greatly appreciated.

--Danica
DGibson111
PL Nut
 
Posts: 31
Joined: 10:44pm, Wed 07 Nov, 2007

Re: Mailer Error: Language string failed to load: connect_ho

Postby DGibson111 » 11:33pm, Wed 07 Nov, 2007

I just wanted to also mention that there is no space in between the secureserver . net but I couldn't cut and paste exactly because of new user limitations.
DGibson111
PL Nut
 
Posts: 31
Joined: 10:44pm, Wed 07 Nov, 2007

Re: Mailer Error: Language string failed to load: connect_ho

Postby DGibson111 » 12:18am, Thu 08 Nov, 2007

I've also just noticed that if I take out the smtpout . secureserver . net and leave the default I get a successful message and I get a success when sending a test message BUT I never receive the confirmation or test message. Is there just a long delay? How do I resolve this? Please help. Thanks!
DGibson111
PL Nut
 
Posts: 31
Joined: 10:44pm, Wed 07 Nov, 2007

Re: Mailer Error: Language string failed to load: connect_ho

Postby DGibson111 » 2:51am, Thu 08 Nov, 2007

ignore this
Last edited by DGibson111 on 3:14pm, Sun 11 Nov, 2007, edited 1 time in total.
DGibson111
PL Nut
 
Posts: 31
Joined: 10:44pm, Wed 07 Nov, 2007

Re: Mailer Error: Language string failed to load: connect_ho

Postby DGibson111 » 3:13pm, Sun 11 Nov, 2007

It is working correctly now.

I had to remove the smtpout.secureserver.net and also had to put in the username and password. config.php file looks like this now



define("PHPMAILERHOST",'');
$phpmailer_smtpuser = 'user[at]mydomain[dot]com';
$phpmailer_smtppassword = 'mypassword';

$phpmailer_smtpport = '80';


I used the port 80 because that is what my hosting provider supports.

I also wanted to mention that since I have go daddy hosting I had to use the full user + domain for the username.

I also found a referend to a bug and wanted to note that I made this change also http://mantis.phplist.com/view.php?id=8590

Lastly, for ease of searches I'd like to include the following terms godaddy godaddy.com. Oh, I am also running phplist version 2.10.5


--Danica
DGibson111
PL Nut
 
Posts: 31
Joined: 10:44pm, Wed 07 Nov, 2007

Re: [solved] Mailer Error: Language string failed to load

Postby FabioLima » 6:38pm, Thu 25 Jun, 2009

Hi Danica.
I'm having the same problem but this option don't worked for me.
Do you have a another way to resolve this?
That is my config.php file:
Code: Select all
# If you want to use the PHPMailer class from phpmailer.sourceforge.net, set the following
# to 1. If you tend to send out html emails, it is recommended to do so.
define("PHPMAILER",1);

# To use a SMTP please give your server hostname here, leave it blank to use the standard
# PHP mail() command.
define("PHPMAILERHOST",'server.domainindicated.ws');

# if you want to use smtp authentication when sending the email uncomment the following
# two lines and set the username and password to be the correct ones
$phpmailer_smtpuser = 'myuser';
$phpmailer_smtppassword = 'mypassw';
$phpmailer_smtpport = '25';


In the line $phpmailer_smtpport = '25'; i take experienced but not show difference.
In the line $phpmailer_smtpuser = 'myuser'; i take experienced 'myuser[at]server.domainindicated.ws', 'myuser+server.myserverdomain.ws' but not show difference too...

In both cases, it seems that the PHPList unable to connect to the server, or does not use the server specified, but which is hosted...
FabioLima
PL Nut
 
Posts: 18
Joined: 7:14pm, Fri 12 Jun, 2009

Re: [solved] Mailer Error: Language string failed to load

Postby lucablue » 7:18pm, Thu 28 Jan, 2010

My SMTP server need "server requires authentication"... How can I insert it into config.php ?
lucablue
PL Nut
 
Posts: 20
Joined: 2:56pm, Wed 27 Jan, 2010


Return to Advanced Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 2 guests