Bounce processing - Cannot create POP3 connection

Once you've installed phpList Version 2... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

Bounce processing - Cannot create POP3 connection

Postby yebaws » 10:25pm, Wed 21 Mar, 2007

I am having problems with bounce handling. Everything else is working fine and bounced messages are retuned to the mailbox that I have set up for them, but when I try and process bounces, I get:

Cannot create POP3 connection to pop3.mydomain*com: Connection failed to pop3.mydomain*com,110: Connection timed out
Identifying consecutive bounces
Nothing to do
Identifying consecutive bounces
0 users processed

Settings in my config file are:

$message_envelope = 'ptbnc@mydomain*com';
$bounce_protocol = 'pop';
$bounce_mailbox_host = 'pop3.mydomain*com';
$bounce_mailbox_user = 'myusername';
$bounce_mailbox_password = 'xxxxx';
$bounce_mailbox_port = "110/pop3/notls";

I have tried using $bounce_mailbox_port = "110/pop3";
with the same result. The mailbox settings are all correct and can be tested by putting them into outlook express as a new account, and there are bounced emails waiting in the account.

I notice that for bounce handling to work, imap support must be enabled and php must be "without safe_mode". I don't know wheter this is the case on my server and I will ask - could they be causing this problem?

Thanks,

J

BTW, .'s are replaced with *'s in the above settings because this forum would not let me post a "URL"
yebaws
phpList newbie
 
Posts: 2
Joined: 10:05pm, Wed 21 Mar, 2007

Re: Bounce processing - Cannot create POP3 connection

Postby H2B2 » 2:38am, Thu 22 Mar, 2007

yebaws wrote:$bounce_mailbox_user = 'ptbnc';

You could check this setting. It might be ptbnc@mydomain.com
Usually the settings that work in your email client should work here too.
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby yebaws » 8:34am, Thu 22 Mar, 2007

$bounce_mailbox_user = 'ptbnc'; is correct for my sytem. When collecting mail with my mail client, this is the username that I use - just the alias before the @
yebaws
phpList newbie
 
Posts: 2
Joined: 10:05pm, Wed 21 Mar, 2007

Postby H2B2 » 12:53pm, Thu 22 Mar, 2007

In that case you'd best contact your ISP about this issue.
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby xapi » 5:11pm, Tue 06 May, 2008

I love it when you have a problem with getting something to work and you do your due diligence to look in the forum, and then you find someone with EXACTLY the same problem as you! But then you get to the bottom of the post and there's no resolution...

So I've got the same issue and I'm filled with suspense...did you get it working? How? Was it a server issue?

I think my issue could be related to the fact that phplist is running on my bluehost shared web server but we run our own mail server here in the office. I even tried using my mail server's static IP instead of mail*eternalvision*org just in case, but I still get the "timed out" error when it tries to process the bounces.

At this point, I'm still testing - don't want to go live until this is sorted out. Hope someone knows the solution!
xapi
phpList newbie
 
Posts: 2
Joined: 5:05pm, Tue 06 May, 2008

Postby H2B2 » 9:33pm, Tue 06 May, 2008

The "Connection timed out" error when trying to connect with your pop account is mentioned in a couple of other threads, e.g.: http://forums.phplist.com/viewtopic.php?p=25075

In this case seemed to be related to the use of SSL.
See also: http://forums.phplist.com/viewtopic.php?p=32266#32266
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby snakesmaster » 10:35am, Fri 20 Jun, 2008

Did you solve the problem? I have the same problem.
snakesmaster
PL Nut
 
Posts: 21
Joined: 8:00am, Thu 12 Jun, 2008

Postby xapi » 1:58pm, Fri 20 Jun, 2008

@snakesmaster: No, I never got it to work with my on-site mail server. I had to use a workaround by using my webserver (most have a mail server function that goes along with; config through the cpanel). I setup the bounce email to use one of my parked domain names that I don't manage with my on-site mail server. So that seems to work OK, just not ideal. And it certainly wouldn't work for you if you don't have any secondary parked domain names that you aren't using...
xapi
phpList newbie
 
Posts: 2
Joined: 5:05pm, Tue 06 May, 2008

Postby snakesmaster » 3:17pm, Fri 20 Jun, 2008

Well as I read in the config file this function don't work in safe mode, maybe thats the problem in my case.
snakesmaster
PL Nut
 
Posts: 21
Joined: 8:00am, Thu 12 Jun, 2008

Bounce Email Collection settings

Postby robiw » 2:01pm, Fri 04 Jul, 2008

Experiencing same problem. Added 3 misspelled email addresses manually and processed queue.

Have tried the options outlined with settings:-

$message_envelope = 'maillist@domainname.co.uk';
$bounce_protocol = 'pop';
$bounce_mailbox_host = 'pop.domainname.co.uk';
$bounce_mailbox_user = 'maillist@domainname.co.uk'; (correct user)
$bounce_mailbox_password = 'listmail';
#$bounce_mailbox_port = "110/pop3/notls"; (tried both)
$bounce_mailbox_port = "110/pop3";

php_safe_mode is set to off.

No bounces appear to be identified and none are in mailbox. Is there another setting I'm missing?
robiw
phpLister
 
Posts: 6
Joined: 1:12pm, Wed 02 Jul, 2008
Location: Bo'ness, Scotland

Postby Guest » 2:53pm, Tue 14 Oct, 2008

I experienced the pop3 connection problem and I resolved replacing :


$bounce_mailbox_host = 'pop.mydomain.com';

with

$bounce_mailbox_host = 'localhost';

..and it worked!

Bye
Guest
 

Postby Guest » 7:18am, Tue 21 Oct, 2008

Same problem here. I have read all these posts and can't figure out how to resolve it. I have tried both LocalHost, as well as what I have here for my mailbox and it didn't make a difference. I am not using GMail - so that's not the issue.


I am trying to post my code, but it keeps telling me I can't post a link since I am a new member. However, I am not posting links. I don't know what else to do except describe the issue since I can't post the code.
Here is what I have:
$message_envelope = 'my email addy';

# when the protocol is pop, specify these three
$bounce_mailbox_host = 'doesn't work with localhost or with the pop info';
$bounce_mailbox_user = 'my addy';
$bounce_mailbox_password = 'password';
Last edited by Guest on 7:30am, Tue 21 Oct, 2008, edited 1 time in total.
Guest
 

Postby Guest » 7:23am, Tue 21 Oct, 2008

Ok - no longer getting the message that it can't connect. Now I get:
0 bounces to fetch from the mailbox
Please do not interrupt this process
Closing mailbox, and purging messages
Identifying consecutive bounces
Nothing to do
Identifying consecutive bounces
0 users processed

I know there are invalid, confirmed addy's in there. Why isn't it picking them up?
Guest
 

Postby wilsoncortez » 5:47am, Fri 31 Oct, 2008

Hi

Exactlly the same problem here.

I can receive the bounces through Outlook express but the never appear at phpList ...

Any help?

Thanks in advance
wilsoncortez
PL Nut
 
Posts: 15
Joined: 8:53pm, Fri 09 Nov, 2007

Re: Bounce processing - Cannot create POP3 connection

Postby alexwawo » 5:26am, Tue 29 Jun, 2010

Hi all,

previously I got the same error, then I use this:

$bounce_mailbox_port = "110/pop3";

instead
#$bounce_mailbox_port = "110/pop3/starttls";

hope this can help.

Thanks,
Alex
alexwawo
phpList newbie
 
Posts: 2
Joined: 8:16am, Wed 23 Jun, 2010

Next

Return to Question & Problems - after installing

Who is online

Users browsing this forum: No registered users and 1 guest