[fix] Pound Signs in Text part of emails replaced by '?'

Solutions for other advanced phplisters

[fix] Pound Signs in Text part of emails replaced by '?'

Postby Mike_R » 9:58am, Wed 06 Jun, 2007

Just spent a good couple of hours searching for the solution to this one. I have manual text part enabled in config.php, and whenever I used £ in the text part, it would come out as a ? in Thunderbird. (Seems the email was always being sent encoded as iso-8859-1, as things displayed correctly when I manually swapped the encoding in Thunderbird).

Couldn't find a way to stop phplist sending the header
Code: Select all
Content-Type: text/plain; charset="UTF-8"
with the email, despite changing various configuration options (and hacking little bits of the code at what looked like promising places.

Easier solution was found by editing the language file ( /texts/english.inc ) and changing the encoding on the first line to read UTF-8. Then open message, save message (at which point the £ that were on screen suddenly display as ? again), replace the ? with £ and re-save, then all is well with the world.[/code]
Mike_R
PL Geek
 
Posts: 88
Joined: 10:34am, Wed 30 May, 2007

Return to Advanced Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 1 guest

cron