Experience with first using/installing/configure phplist

Solutions for other advanced phplisters

Experience with first using/installing/configure phplist

Postby bofh » 6:51pm, Fri 07 Mar, 2008

I was really glad that I found your tools.
So this is my experience as and admin and not so much programmer with a little knowledge to read a code.
I thought I could write my experiences while trying to install php tools with some help of my LinxAdmin.

This is more like power user comment and not so exact programmers code. But I hope it could help all you guys who are developing that tools.

After installing we soon got to the first problem:

1. utf-8 and Slovenian code page and special character

Comment: This was quite a tuff error. I spend a lot of time trying to figure out what was wrong. MySQL is already installed on server, working with no problem and we had no trouble with our special characters so far!

Solution: LinxAdmin did what was suggested on a forum, he corrected a part of code that check and correct the code page on every connection to the database. He also mentioned that utf-8 had problem with e-mail length of 255 chars so he change it to 200

NEXT; so after solving this problem we got a new one!

2. There was a strange behaviour of created links.
If I put in a website: DOMAIN/phplist a lot of things worked, but after creating an email links just added another /phplist ... probably from config file root="/phplist" and "Website address"

I had to change this param depends on what I wanted to do ... but unfriendly to user :-)

This behaviour caused that when I pressed option SEND A MESSAGE application just hangs... but indeed a lot (like 30/second) draft e-mails were created... as long as I didn't stopped this page and move on.
Now my msg had number like 2400 :-)

Creating links in an e-mail msg (when I wanted to use statistic) was also wrong /phplist/phplist/....

Solution/Comment: LinxAdmin's comment on that was that there was different approach on creating links (in e-mail) and using variable $pageroot = '/phplist'; and "website".

3. STILL ONGOING PROBLEM
Importing cvs file with our characters is creating trouble.... if there is our special character... it won't import.. because file is in a different code page ....

Hope we will also solve this problem.
bofh
phpLister
 
Posts: 6
Joined: 5:50pm, Fri 07 Mar, 2008

Return to Advanced Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 2 guests