Page 1 of 1

[mod] disable eventlog

PostPosted: 11:29am, Sat 29 Mar, 2008
by thisisit3
Is it possible to disable the eventlog? So that it doesn't keep any events at all and remains empty?

PostPosted: 3:59pm, Sun 30 Mar, 2008
by H2B2
I don't think there's a simple configuration option to disable the eventlog. However, you should be able to set admin permissions for the eventlog, just in case you do not want all administrators to have access to the eventlog.
Ref: http://docs.phplist.com/SettingAdminPermissionsInfo

PostPosted: 4:19pm, Sun 30 Mar, 2008
by thisisit3
No, thats not what i want. I need to disable the eventlog so that phplist doesn't fill the entire diskspace with garbage.

Patchy, but quick way to disable eventlog posting

PostPosted: 1:52am, Wed 02 Apr, 2008
by trautwein101
Option One:
I had the same problemo, code-wise in the lists/config/config.php make sure that your setting is below. lostndazed from post below offers this solution.

-->Sorry guys who deserve crdit I am still blocked from posing forum URL :evil:

//////////////////////////////////////////////
To turn off the eventlog, then I would put:

Code:
define ("NOSTATSCOLLECTION",1);
//////////////////////////////////////////////

**What I did!, its ugly-very ugly! but I dont have the time to parse through the php code to find the snap...I know its a wasted function call, etc...BUT

Thanks to PL Nut who identified the quick location in the lib.php file around line #451. I just commented out the event :idea:

function logEvent($msg) {
global $tables;
if (isset($GLOBALS['page'])) {
$p = $GLOBALS['page'];
} elseif (isset($_GET['page'])) {
$p = $_GET['page'];
} elseif (isset($_GET['p'])) {
$p = $_GET['p'];
} else {
$p = 'unknown page';
}
/*
if (Sql_Table_Exists($tables["eventlog"]))
Sql_Query(sprintf('insert into %s (entered,page,entry) values(now(),"%s","%s")',$tables["eventlog"],
$p,addslashes($msg)));
*/
}



Hope this helps someone
:wink:

Jason

PostPosted: 5:13am, Wed 02 Apr, 2008
by thisisit3
niiiiiiice!

thank you!

PostPosted: 5:18am, Wed 02 Apr, 2008
by thisisit3
oh btw, the next step would be to completely delete the email from the "messages" once it has finished sending itself.

since right now, the "messages" section is filling up and there is no reason for it.