Please help: FastCGI Error

Solutions for other advanced phplisters

Please help: FastCGI Error

Postby Guest » 1:49pm, Sun 17 Aug, 2008

Hi
I have been using PHPList for about a year now with great success. I send out a weekly e-bulletin to just under 10 000 subscribers. For some reason this week when I tried to send it I just get the following message:

FastCGI Error
The FastCGI Handler was unable to process the request.

Error Details:

* The FastCGI process exceeded configured activity timeout
* Error Number: 258 (0x80070102).
* Error Description: The wait operation timed out.

HTTP Error 500 - Server Error.
Internet Information Services (IIS)


I have been looking all over this forum and the internet for any clues as to what this problem might be or how I could go about fixing it. So far no luck - was wondering if anyone on here had any ideas.
Any help would be greatly appreciated.
Guest
 

Postby Guest » 6:09pm, Sun 17 Aug, 2008

after contacting my shared server host I received the following reply:

FastCGI has been used as part of the upgrade from PHP 4 to PHP5 on our servers. The error message indicates that the script is timing out. There is a 30 second limit before a script will time out on our servers. We wold suggest looking at ways to reduce the time your script takes to process.

Does anyone have any suggestions as to what I should do? How can I change the duration of the script?
is this something in the config.php file?

any help would be greatly appreciated
Guest
 

Postby Ernesto » 10:26pm, Sun 17 Aug, 2008

The following post suggests that some hosts provide a way to disable FastCGI in Cpanel:
jeremiah wrote:I had exactly the same problem - large batch sent to many lists - shared account with Bluehost, after 100's of successful runs, it just randomly started throwing the 2006 error.

Solved it by temporarily disabling FastCGI processing - if your ISP provides this automatically, you should have a setting for it in your cpanel. Try disabling it and then re-queue your batch - then once you can run process queue successfully again, you should be able to re-enable FastCGI.

I don't know much about exactly how FastCGI works, but I've had similar problems before and this was the fix - seems that it will sometimes cache a bad query or script and prevent it from ever being re-loaded correctly.
See http://mantis.phplist.com/view.php?id=8905
Search first, Ask questions later...
Ernesto
PL Freak!
 
Posts: 592
Joined: 2:25am, Thu 08 Jun, 2006

Postby Guest » 1:39pm, Mon 18 Aug, 2008

hey - thanks for your suggestion. I also read that post but sadly my hosting provider does not have an option to turn FastCGI on or off - I have requested to be moved over onto a linux server and this will hopefully give me the control I require.
Guest
 

Postby Guest » 5:23pm, Mon 18 Aug, 2008

just got a reply from my hosting supplier that they do not grant access to change server settings - I am completely stuck now! does anyone have any suggestions as to how I can work around this?
Should I be looking at running a cron job?
Guest
 

Re: Please help: FastCGI Error

Postby dc2010 » 9:26am, Wed 21 Jul, 2010

you should also check the FastCGI settings, as described here
http://learn.iis.net/page.aspx/248/conf ... or-iis-60/

I had a timeout error coming up every time on a subscriber import operation (+4500 users in CSV)

raising the limits in fcgiext.ini (System32\inetserv) did the trick for me
dc2010
phpList newbie
 
Posts: 1
Joined: 9:19am, Wed 21 Jul, 2010

Re: Please help: FastCGI Error / solved this way

Postby nick » 11:56pm, Thu 09 Dec, 2010

Hi,

I had the same problem and tried almost everything suggested. At the end I could solve the problem by changing the apache config file.

The Apache error showed:
[Fri Dec 10 00:03:27 2010] [warn] (110)Connection timed out: mod_fcgid: ap_pass_brigade failed in handle_request function
[Fri Dec 10 00:06:18 2010] [warn] mod_fcgid: read data timeout in 31 seconds

My solution:

You can adjust the timeout for Apache IPC (which I think is the only timeout that effects fcgid) using these two directives in httpd.conf:

IPCConnectTimeout 20
IPCCommTimeout 300
(The number are seconds)

After changing the IPCCommTimeout to a bigger number than 31 PHPlist sent all emails out.

If don't have access to the config file, you may ask your provider to change it.
Hope this helps.

Nick

Redhat Linux Fedora 8 / Apache 2.2.8 / PHP 5.2.6
nick
phpList newbie
 
Posts: 4
Joined: 10:08am, Thu 17 Apr, 2003


Return to Advanced Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 1 guest