3 bug : white page, html entities, email partialy sent

Solutions for other advanced phplisters

3 bug : white page, html entities, email partialy sent

Postby masdeeper » 7:42am, Sun 21 Mar, 2010

First, html entities was not working and I was getting strange character instead of my usual foreign letter like "é è ç"
Even if I checked to receve HTML emails..
I tried to change UTF-8 without success

I discovered that when you mass import userthe "Send this user HTML emails" option don't work..
So you must do the "mark all users to receive html" in the reconcile page...
Voila :D


Second bug whas that some of my emails where partially sent. By checking the source code I saw that after X character phplist stopped to send data.
To solve this you must change change the database field type of phplist_message.message to longtext


Third one, some mail client show a white page instead of the actual email. (hotmail, outlook, etc)
This is because when user copy/paste from Words to fckeditor in firefox,saffari the option to clean the text don"t show up... So you send emails with:
<!--[if gte mso 9]>
This is a regular HTML comment.. No problem if your email reader don't support this function..
Other wise this is a regular if/elese ... If mail client is ♦microsoft outlook (mso 9) do this...

:D
masdeeper
phpLister
 
Posts: 12
Joined: 10:00am, Tue 29 Sep, 2009

Re: 3 bug : white page, html entities, email partialy sent

Postby H2B2 » 2:06pm, Mon 22 Mar, 2010

Thanks for sharing your findings.
if you are running v2.10.10, you'll need to apply a number of bug fixes, including some of the ones you mentioned in your post. Most have been listed here: See Listing of reported bugs and fixes - 2.10.10 .
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006


Return to Advanced Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 1 guest