2.11.5 dev: Problem with editing message

Discuss, research, share, find, and solve bugs

2.11.5 dev: Problem with editing message

Postby duncanc » 8:53pm, Wed 14 Jul, 2010

I am trying the new dev version, 2.11.5, and have a problem with editing a message.

I upgraded from 2.10.12 with no real problems but when I create a new message the message body area is not displayed, only the Subject, From line and Message Footer are displayed. If I then edit the message the message body area is still not displayed.
ScreenShot001.gif
ScreenShot001.gif (5.2 KiB) Viewed 7110 times

However if I edit a draft message that was migrated from 2.10.12 then the message body is displayed.

I have tried editing the new message using phpmyadmin and setting the message body but it is still not displayed.
Also, compared the message table records for the migrated record and the new one and cannot see any significant difference.

Any ideas?
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: Problem with editing message with version 2.11.5

Postby H2B2 » 10:32am, Tue 20 Jul, 2010

Haven't yet installed dev2.11.5, but had a quick look at the online demo: http://dev.phplist.com/lists/admin/ which has the 'manual text part' setting enabled in config.php.

When clicking on Send a campain > start a new message, you should see the following option:
    Send your message from:
    * a URL (website) * Enter it here
If you select 'Enter it here', the input box for your raw HTML code is displayed (FCKeditor seems to be disabled in the demo), along with the manual textpart input box beneath it.

Did you select the 'Enter it here' option when trying to create a new message?
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: Problem with editing message with version 2.11.5

Postby duncanc » 2:05pm, Tue 20 Jul, 2010

Thanks for the pointer to the dev system. On the About page that seems to be running version 2.11.5-dev whereas the downloaded version is 2.11.5, so there are likely to be some differences between them.

When creating a new message I don't get any of the three field groups: Send your message from, URL, or Plain text. The screenshot is pretty much what is displayed.

I did some digging in the code yesterday and found what seems to cause part of the problem. I had previously raised an issue in Mantis and added my further comments yesterday - http://mantis.phplist.com/view.php?id=15517
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: Problem with editing message with version 2.11.5

Postby H2B2 » 2:59am, Wed 21 Jul, 2010

duncanc wrote:seems to be running version 2.11.5-dev whereas the downloaded version is 2.11.5, so there are likely to be some differences between them.

Yes, that is possible, though when looking at http://sourceforge.net/projects/phplist/develop the only change since release 2.11.5 is revision 2172, which involves a file not related to this issue.

Perhaps a long shot: It seems 2.11.5 uses iconv in some parts of the code, even though this is apparently not a standard php module. Systems that do not include iconv are reported to have had trouble when trying to create or edit a message in v2.10.12. See http://mantis.phplist.com/view.php?id=15463
Could you check if you have the iconv module included in your PHP installation?

Think I'll find some time to setup up a v2.11.5 sandbox in the coming week and run some tests of my own. Hope I'll be able to check your findings by then.
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: Problem with editing message with version 2.11.5

Postby duncanc » 6:25am, Fri 23 Jul, 2010

Thanks for your further reply. I had already had a look at the SVN repository in sourceforge, and the two files that I mentioned in the Mantis issue seem to be the same as those in the 2.11.5 distribution.

Checked iconv and it is installed

iconv support enabled
iconv implementation glibc
iconv library version 2.7

All of this on my home Ubuntu netbook, so I also installed 2.11.5 on my shared hosting production server and had the same result.

I await you or anyone else installing 2.11.5 and confirming my results or telling me what I'm doing wrong!
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: Problem with editing message with version 2.11.5

Postby jurij » 9:26am, Mon 26 Jul, 2010

I have exactly the same problem, but with clean install of dev version.
PHPlist is hosted and iconv is enabled
jurij
phpLister
 
Posts: 9
Joined: 1:51pm, Wed 10 Mar, 2010

Re: Problem with editing message with version 2.11.5

Postby jurij » 9:33am, Mon 26 Jul, 2010

jurij wrote:I have exactly the same problem, but with clean install of dev version.
PHPlist is hosted and iconv is enabled


Code: Select all
    * phplist version: 2.11.5
    * PHP version: 5.2.9
    * Browser: Mozilla/5.0
    * Webserver: Apache
    * Website:
    * Mysql Info: 5.0.90-community-log
    * PHP Modules:
          o zip
          o libxml
          o xsl
          o xmlwriter
          o xmlrpc
          o dom
          o xmlreader
          o xml
          o wddx
          o tokenizer
          o tidy
          o session
          o pcre
          o SimpleXML
          o sockets
          o soap
          o SPL
          o standard
          o Reflection
          o pspell
          o posix
          o pgsql
          o mysqli
          o mysql
          o mime_magic
          o mhash
          o mcrypt
          o mbstring
          o json
          o imap
          o iconv
          o hash
          o gettext
          o gd
          o ftp
          o filter
          o exif
          o date
          o curl
          o ctype
          o calendar
          o bz2
          o bcmath
          o zlib
          o openssl
          o cgi
jurij
phpLister
 
Posts: 9
Joined: 1:51pm, Wed 10 Mar, 2010

message content missing (message area)

Postby accman » 6:03pm, Mon 26 Jul, 2010

Hi
I am new user of phplist. I install it and imported the contacts list.

when I go to send message, only the following items displayed:

Content Format Scheduling lists Misc

Subject:

? From Line:

? Message Footer.
Use [UNSUBSCRIBE] to insert the personal unsubscribe URL for each user.
Use [PREFERENCES] to insert the personal URL for a user to update their details.
Use [FORWARD] to add a personalised URL to forward the message to someone else.


but there is no contents portion, where I can write the message.
above it says : ' message content missing' in red.

I tried many suggestions that are given in the forum, but no one is working here.
I have edited config.php, send_core etc. and tried but no success.

I am using phplist ver: 2.11.5.


Any help please.

Ayub
accman
phpList newbie
 
Posts: 1
Joined: 5:27pm, Mon 26 Jul, 2010

Re: Problem with editing message with version 2.11.5

Postby duncanc » 6:25pm, Mon 26 Jul, 2010

As you are a new user of phplist then you should install the latest stable version, 2.10.12 which works very well.

The version 2.11.5 is a development version and not for production use, as it says on the home page.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: Problem with editing message with version 2.11.5

Postby duncanc » 6:41pm, Mon 26 Jul, 2010

jurij wrote:I have exactly the same problem, but with clean install of dev version.
PHPlist is hosted and iconv is enabled


Thanks for confirming that. I have found some details of the problem and updated the Mantis issue.

The problem does not occur if you install the HTTP_Request package. This package allows you to use a remote URL as the source of a message (I don't).

Or this is a workaround if you don't need to use a remote URL as the source of a message.
in admin/lib.php
line 128
'sendmethod' => 'remoteurl', ## make a config

change to

'sendmethod' => 'inputhere', ## make a config
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: Problem with editing message with version 2.11.5

Postby H2B2 » 9:27pm, Tue 27 Jul, 2010

duncanc wrote:The problem does not occur if you install the HTTP_Request package. This package allows you to use a remote URL as the source of a message (I don't).

Or this is a workaround if you don't need to use a remote URL as the source of a message.
in admin/lib.php
line 128
'sendmethod' => 'remoteurl', ## make a config

change to

'sendmethod' => 'inputhere', ## make a config

Nice find! And an effective fix.
My test system is indeed missing the HTTP_Request module, and I was able to reproduce the issue you described in your first post.

Applying the workaround you suggested seems to work fine. The FCKeditor window is now displayed.

Thanks!
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: 2.11.5 dev: Problem with editing message

Postby Houi » 3:10am, Sun 12 Dec, 2010

I upgraded to 2.11.5 a couple of months back and it's been working fine. Then today the message body disappears. Luckily the workaround above does the trick 8)
Houi
phpList newbie
 
Posts: 2
Joined: 2:57am, Sun 12 Dec, 2010


Return to Bug Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron