Page 1 of 1

PHP 5.3 issue

PostPosted: 3:52pm, Thu 16 Aug, 2012
by NYChris
How far off is the next release and will it have all the deprecated PHP 5.3 functions replaced?

I have a need to install PHPList on another dedicated server running PHP 5.3
However, the Softaculous installer craps out due to the incompatibility issue and I don't want to do a manual install if so many functions are incompatible.

If the next version is too far off, maybe a quick fix would be to put the deprecated functions into the PHPList included library for now (../admin/commonlib/lib/)?

If that's not going to work, maybe somebody could make a complete list of files using deprecated functions and how to change the functions?

I know it's a big ask and I wouldn't bother if it wasn't very important to me (and others, I'm sure).

Re: PHP 5.3 issue

PostPosted: 6:03pm, Fri 17 Aug, 2012
by duncanc
I'm running phplist on PHP 5.3.10 in a shared hosting environment with no problems. Also running with PHP 5.3.10 on Windows (WAMP) and some release of 5.3 on Ubuntu.

phplist has error reporting turned off (in general a bad thing) so warnings about deprecated functions don't get reported.

I don't think that the deprecated functions are going to be removed from the 2.10.x version, only from the 2.11.x version. I did notice that the ereg* functions had been replaced by preg* or by string functions in the sendemailllb.php file in the 2.11 source, but don't know whether the change has been made throughout.

However deprecated functions are purely that, deprecated. They will be removed some time in the future but still do work.

Re: PHP 5.3 issue

PostPosted: 7:02pm, Fri 17 Aug, 2012
by Dragonrider
One of my hosts recently moved my sites hosted on their web space to 5.3. Surprisingly the affected phpList installs seemed to work perfectly under 5.3, in my case it was the older CMS installs that included phpList that crashed on the move!

So, I too will say that phpList seems to be quite happy under PHP5.3.

Re: PHP 5.3 issue

PostPosted: 6:13am, Wed 22 Aug, 2012
by softaculous
Hi,

I am from the Softaculous team. We have disabled the installation for servers running PHP 5.3 because it is stated on the PHPList Requirements page :
http://docs.phplist.com/SystemRequirements.html

If the PHPList developers can change it or if they can confirm that PHPList works without any errors on PHP 5.3+ then we will remove the check immediately.

Re: PHP 5.3 issue

PostPosted: 5:22am, Mon 27 Aug, 2012
by JoeTorma
softaculous wrote:Hi,

I am from the Softaculous team. We have disabled the installation for servers running PHP 5.3 because it is stated on the PHPList Requirements page :
http://docs.phplist.com/SystemRequirements.html

If the PHPList developers can change it or if they can confirm that PHPList works without any errors on PHP 5.3+ then we will remove the check immediately.


I am running phpList version 2.10.19 on php version 5.3.15 without issue. FYI - I installed via Softaculous, also...

Re: PHP 5.3 issue

PostPosted: 1:42pm, Tue 28 Aug, 2012
by softaculous
Hi,

We have removed the PHP 5.3 check for PHPList.

Please execute the CRON command to get the latest package and then you should be able to install it on any PHP version.
http://softaculous.com/docs/Immediate_update