the accent characters looks like ������

General talk about translations & I18n (Internationalization)

the accent characters looks like ������

Postby dkaip » 8:49am, Thu 10 Mar, 2011

Hello all. From cpanel -> fantastico i install phplist. The databese collation is latin1_swedish_ci for all tables. When i send a message the accent Greek characters is like ��������
When i save a message the subject(Greek language) immediately look like #973;με τι θα φτάσε&#9
When receive message the body is like ...
Τ� ν� πο�με ρ� παιδι� ..
I don't know what i must do.
Thank's
Jim
dkaip
phpLister
 
Posts: 6
Joined: 9:35pm, Wed 09 Mar, 2011

Re: the accent characters looks like ������

Postby H2B2 » 3:24pm, Thu 10 Mar, 2011

You could take a look at this tutorial: How to configure UTF-8 in phpList
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: the accent characters looks like ������

Postby dkaip » 7:33am, Tue 15 Mar, 2011

Trying to send Greek messages with phplist characters are like ???????
I make all except ...
On the 'configuration page', check these settings:
- Charset for HTML messages: UTF-8
- Charset for Text messages: UTF-8

Where is configuration page? Maybe phplist > configuration or config.php?
On database I try the ...
ALTER DATABASE myData DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci

and the results are ...
character_set_client utf8
character_set_connection utf8
character_set_database latin1
character_set_filesystem binary
character_set_results utf8
character_set_server latin1
character_set_system utf8
character_sets_dir /usr/share/mysql/charsets/
collation_connection utf8_unicode_ci
collation_database latin1_swedish_ci
collation_server latin1_swedish_ci

character_set_database must be utf8 but it is latin1.
Any idea what i must do?
Thanh's
dkaip
phpLister
 
Posts: 6
Joined: 9:35pm, Wed 09 Mar, 2011


Return to Translators & Internationalization

Who is online

Users browsing this forum: No registered users and 1 guest