Umlaute im Betreff

Umlaute im Betreff

Postby r2d2 » 9:55am, Mon 29 Oct, 2007

Hallo!

Habe irgendwie ein Problem mit Umlauten im Betreff.

Wenn der Betreff z.b. lautet: Testmail
Dann passt alles. Im Quelltext der versendeten Nachricht wird auch bei Subject: Testmail angezeigt.

Lautet der Betreff jetzt aber: Testmäil
Dann wird im Thunderbird z.B. als Betreff nur eine schwarze Raute mit weißen Fragezeichen angezeigt. Und im Quelltext steht bei Subject: =?UTF-8?Q?Testm=E4il?=

Ansonsten funktionieren Umlaute und Sonderzeichen im Text der Mails.

Weiß da jemand Rat dazu? Dankeschön!

lg, r2d2
r2d2
phpList newbie
 
Posts: 3
Joined: 1:42pm, Mon 30 Jul, 2007

Postby c2n-IT » 9:31am, Thu 15 Nov, 2007

Das kenn ich, is ne Frage der Zeichencodierung im Thunderbird...

Geh mal auf Ansicht -> Zeichencodierung und wähle da "Westlich (ISO-8859-15)"

Das kannst auch noch als Standard nehmen, via Extras -> Einstellungen -> Ansicht -> Formatierungen -> Schriftarten und Kodierung...

Danach war das "Umlautproblem" bei mir gelöst!
c2n-IT
phpList newbie
 
Posts: 1
Joined: 12:13pm, Wed 14 Nov, 2007

Postby Green_Hornet » 5:44pm, Thu 19 Feb, 2009

Es liegt nicht wirklich am eMail-Programm.

Gehe auf deine Admin-Seite -> Konfiguration -> runter scrollen, und dann:

Bearbeiten Charset for HTML messages
iso-8859-1

Bearbeiten Charset for Text messages
iso-8859-1

Nun sollte es klappen.

Grüße, Jan
Green_Hornet
phpList newbie
 
Posts: 4
Joined: 5:32pm, Thu 19 Feb, 2009

Postby lieberhonig » 1:54pm, Tue 24 Feb, 2009

hier mein post aus einem anderen (englischen) thread:

here are many threads concerning this problem, i tried everything described but nothing (or only parts of it) worked out.

here is the solution:

1. leave your phplist installation as it is. ("Charset for HTML messages" and "Charset for Text messages" shoud be set to UTF-8, if not change it.)

2. edit the language-file that is set in the config file(!). change ISO-8859-1 to UTF-8. now the backend is rendered in UTF-8, everything should work fine now.
lieberhonig
phpList newbie
 
Posts: 2
Joined: 1:31pm, Tue 24 Feb, 2009

Re: Umlaute im Betreff

Postby promostage » 2:52pm, Tue 27 Sep, 2011

Ok, alter Thread, muss ihn leider trotzdem nochmal aufwärmen :?

(PHPList Version: 2.10.17)

Ich schaffs nicht, die Codierungen so einzustellen, dass tatsächlich alles passt! Also nochmal die Bitte um Klarstellung:

Welches sind die empfohlenen Einstellungen, um sämtliche Sonderzeichen/Umlaute/etc. in Text und Betreff verwenden zu können?
Nach 3 Stunden rumprobieren mit verschiedenen Einstellungen sowohl im Konfig-Menü als auch direkt in german,inc/english.inc habe ich leider den Überblick verloren, was wann genau NICHT ging - Fakt: Irgendwas war immer falsch :(

Also: Was muss eingestellt werden in:
- Konfig-Menü (HTML-/Text-Codierung)
- Sprachdateien (german.inc/english.inc/etc.)
- config.php (phpmailer klasse benutzen oder nicht? und wenn nicht, welche Codierungen dann bei HTMLEMAIL_ENCODING und TEXTEMAIL_ENCODING)

Danke!
promostage
phpList newbie
 
Posts: 1
Joined: 2:23pm, Tue 27 Sep, 2011

Re: Umlaute im Betreff

Postby public » 11:44am, Thu 06 Dec, 2012

promostage wrote:Ok, alter Thread, muss ihn leider trotzdem nochmal aufwärmen :?

(PHPList Version: 2.10.17)

Ich schaffs nicht, die Codierungen so einzustellen, dass tatsächlich alles passt! Also nochmal die Bitte um Klarstellung:

Welches sind die empfohlenen Einstellungen, um sämtliche Sonderzeichen/Umlaute/etc. in Text und Betreff verwenden zu können?
Nach 3 Stunden rumprobieren mit verschiedenen Einstellungen sowohl im Konfig-Menü als auch direkt in german,inc/english.inc habe ich leider den Überblick verloren, was wann genau NICHT ging - Fakt: Irgendwas war immer falsch :(

Also: Was muss eingestellt werden in:
- Konfig-Menü (HTML-/Text-Codierung)
- Sprachdateien (german.inc/english.inc/etc.)
- config.php (phpmailer klasse benutzen oder nicht? und wenn nicht, welche Codierungen dann bei HTMLEMAIL_ENCODING und TEXTEMAIL_ENCODING)

Danke!


Ich möchte diesen Thread gerne auffrischen. Kann hier jemand helfen.
Es gibt diverse Threads zu diesem Thema, aber keiner gibt einen konkreten Auffschluss darüber wie die Einstellungen sein sollten.
public
PL Nut
 
Posts: 15
Joined: 6:09pm, Wed 04 Nov, 2009


Return to German forum

Who is online

Users browsing this forum: No registered users and 1 guest