Designproblem bei HTML Mail

Designproblem bei HTML Mail

Postby Hexo » 9:11am, Wed 11 Feb, 2009

Hey.

Ich hab mir ein Template für HTML Mails gebastelt.
Im Thunderbird wird auch alles korrekt, wie gewünscht angezeigt. Allerdings sieht das bei Outlook noch nicht so aus, wie es ein soll. Der Content soll im Blocksatz dargestellt werden. Wir er aber beim Outlook nicht.
Hat jemand einen Idee...

Code: Select all
<html>
<head>
<title>Holyhell Newsletter</title>
<style type="text/css">

body {
 color: #FFFFFF;
 background-color: #1F1F1F;
 font-family: Verdana,Tahoma,Helvetica;
 
}

body a:link, body a:visited, body a:active {
 color: #FF8B3E;
 text-decoration: none;
 
}
body a:hover {
 color: #FFFFFF;
 text-decoration: underline;
 
}

.mainpage {
 background-color: #3F3F3F;
}

.tableoutborder {
 background-color: #000000;
}

.tableinborder {
 background-color: #000000;
}

.smallfont {
 font-size: 10px;
 font-family: Verdana,Trebuchet MS, Arial,Tahoma,Helvetica;
 
}

.normalfont {
 font-size: 11px;
 font-family: Verdana,Trebuchet MS, Arial,Tahoma,Helvetica;
 
}

.tablecat a:hover {
 color: #FFFFFF;
 text-decoration: underline;
 
}

.tableb {
 color: #FFFFFF;
 background-color: #383838;
 border-left: 1px solid #6C6B6B;
border-top: 1px solid #6C6B6B;
}


.tableb_fc {
 color: #FFFFFF;
}


.tableb a:link, .tableb a:visited, .tableb a:active {
 color: #FF8B3E;
 text-decoration: none;
 
}
.tableb a:hover {
 color: #FFFFFF;
 text-decoration: underline;
 
}

.tablea {
 color: #FFFFFF;
 background-color: #313131;
 border-left: 1px solid #6C6B6B;
border-top: 1px solid #6C6B6B;
}

.tablea a:link, .tablea a:visited, .tablea a:active {
 color: #FF8B3E;
 text-decoration: none;
 
}
.tablea a:hover {
 color: #FFFFFF;
 text-decoration: underline;
 
}

.smallfont2 {
 font-size: 9px;
}

.smallfontfooter {
 font-size: 9px;
 font-family: Verdana,Trebuchet MS, Arial,Tahoma,Helvetica;
 font-style: italic;

}
</style>

</head>

<table align="center" cellspacing="0" cellpadding="0" width="710px" border="0">
   <tr>
      <td align="center"><br /><a href="Hier steht ein Link"><img src="newsletter.jpg" border="0" alt="Link" title="Link" /><br /><br /><br /></a>
      </td>

<!--TOP TABLE starts-->

   <tr align="center" valign="top">
       <td align="justify">

                <span class="normalfont">[CONTENT]<br /><br /><br /></span>

       </td>
   </tr>

<!--TOP TABLE ends-->

   <tr>
      <td align="left" width="710px" height="84px" style="entfernt wegen Spamschutz"
         <table cellpadding="0" cellspacing="0" border="0" style="width: 100%; height:84px;">
            <tr>
               <td align="left"><span class="smallfontfooter">[FOOTER]</span>
               </td>
               <td align="right" valign="bottom"><span class="smallfont2"><b>meine Seite</b></span><br /></td>
            </tr>
         </table>
      </td>

   </tr>
</table>

<!--BOTTOM TABLE ends here-->
[USERTRACK]<br />
</body></html>


Gruß Hexo

Ich musste leider alle Links entfernen....
Hexo
phpLister
 
Posts: 7
Joined: 8:05pm, Sun 24 Jun, 2007

Postby cfuture » 11:38am, Thu 12 Feb, 2009

Probier mal folgendes:
Sezte die Justify Anweisung doch mal in die .normalfont Anweisung.
Also:

.normalfont {
font-size: 11px;
font-family: Verdana,Trebuchet MS, Arial,Tahoma,Helvetica;
text-align: justify;
}

Und nimm die Anweisung aus dem Eröffnenden <td> raus. Und erweitere dieses td um style="width:100%"

Oder Du kannst auch das hier probieren

Code: Select all
<div>[CONTENT]</div>


ergänzt um die align="justify" Anweisung. (Krieg ich leider nicht gepostet das align verschwindet dann immer)
Gruss M
cfuture
phpLister
 
Posts: 6
Joined: 11:25am, Thu 12 Feb, 2009

Postby Hexo » 12:39pm, Fri 13 Feb, 2009

Nein, klappt leider nicht. Scheiß Outlook....
Hexo
phpLister
 
Posts: 7
Joined: 8:05pm, Sun 24 Jun, 2007


Return to German forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron