Proable to send text version, not able to send HTML version.

Once you've installed phpList Version 2... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

Proable to send text version, not able to send HTML version.

Postby bobata » 12:35am, Sat 26 May, 2007

Just installed. ...10.4 Via Fantastico.

Testing it out and having this problem:

Using default Fantastico config.

The problem:

I send out a message. Users set to "text" receive an email. Users set to "HTML" receive nothing at all.

PHPlist's confirmation message indicates that all email were successfully sent. I don't see any error anywhere. I reset same user to "text" and they receive the next PHPlist message.


So what happened to the HTML messages???? Where did they go?
bobata
PL Nut
 
Posts: 17
Joined: 2:51pm, Wed 22 Mar, 2006

Postby bobata » 4:48am, Sat 26 May, 2007

Okay, after not finding any answers, and trying to configure/test/reconfigure/test for 3 hours, I came across an old post which appeared un-related, but which fixed the problem:

Here's the config.php setting which I changed from the default "1" to "0" even though I did the opposite of what the comment recommends. I don't know why it works, or if it really has anything to do with the problem I was seeing (all users specified as "HTML" received no mail at all) but somehow disabling that piece allowed something to start working --- partially. Now the HTML emails are showing up -- even though some of the formatting I applied in the editor is missing, who cares, the email is now showing up...

# If you want to use the PHPMailer class from phpmailer.sourceforge.net, set the following
# to 1. If you tend to send out html emails, it is recommended to do so.
#define("PHPMAILER",1);
define("PHPMAILER",0);

If anybody can explain what's going on here, or why the email is going through now and not before, I'd sure like to know. Also wondering if when or how this component gets updated if suddenly the formatting will disappear, reappear, or if the HTML email will start behaving differently in some other way...
bobata
PL Nut
 
Posts: 17
Joined: 2:51pm, Wed 22 Mar, 2006


Return to Question & Problems - after installing

Who is online

Users browsing this forum: No registered users and 10 guests