Page 1 of 1

blacklist or mail problem?

PostPosted: 9:38am, Wed 02 Feb, 2005
by jellybaby
I recently upgraded from 2.8.1, which worked, fine to 2.9.3 and now I'm having trouble.

When you try to subscribe you get this message and no email is sent:
"Sorry, sending the email to request your confirmation failed, please click "Reload" to try again. If it still does not work, it may be because you are listed on our "Black List", which means that you cannot receive emails from our newsletter system. In that case, please contact the administrator."

I checked the user list and the new email has been added but I think it has been automatically blacklisted as the User History says:
"Found user in blacklist while trying to send an email, marked black listed"

And when you sort the users by "show only blacklisted users" the new address appears as such.

The odd thing is that the blacklist tables are empty and I can't find anyway to remove the new user from the blacklist.

Any ideas?

Black list problem

PostPosted: 3:17am, Tue 26 Jul, 2005
by pavansut
I have the exact same problem going on, and it started only three/four weeks ago. Have no idea what might have caused it!

PostPosted: 2:25pm, Tue 01 Nov, 2005
by fneumeier
Has anyone found a solution for this issue? I have exactly the same problem, still with the actual version 2.10.1

Same here

PostPosted: 5:59pm, Thu 17 Nov, 2005
by netmizor
I'm having the same problem. I cannot find a way to un-blacklist the users.

PostPosted: 1:56pm, Mon 28 Nov, 2005
by saul11
I think you'll have to un-blacklist manually by using a DB admin tool like PHPMyAdmin.
You can use these queries:
Code: Select all
TRUNCATE TABLE phplist_user_blacklist;
UPDATE phplist_user_user SET confirmed = 1, blacklisted = 0, modified = NOW();

The first query empties the blacklist and the second un-blacklists everyone.

PostPosted: 12:42pm, Wed 30 Nov, 2005
by michiel
You should be able to unblacklist a user when you view their "history". If that doesn't work, file a bugreport.

Also, users are unblacklisted if they go through the double opt-in process again. That is, even if a user is blacklisted, phplist will still send them the "request for confirmation" email, if they sign up and it will unblacklist them if they confirm their subscription.

Basically the blacklist system is to avoid re-sending emails to users when they are being imported again by an admin, after having unsubscribed. This is to avoid annoyed users who unsubscribed and continue to receive emails. If a user specifically identifies that they want to receive emails again, it will allow them.

PostPosted: 2:20pm, Sat 29 Apr, 2006
by axeplayer
Has anyone found a fix for this yet. I cant use any version higher than 2.8.12

PostPosted: 2:13pm, Tue 06 Mar, 2007
by kurieuo
Old message, but I received this error also (version 2.10.4). Turned SMTP off in config and it worked:

Code: Select all
# To use a SMTP please give your server hostname here, leave it blank to use the standard
# PHP mail() command.
define("PHPMAILERHOST",'');

# if you want to use smtp authentication when sending the email uncomment the following
# two lines and set the username and password to be the correct ones
#phpmailer_smtpuser = '';
#$phpmailer_smtppassword = '';

Same Problem -- PHPList says that new emails are blacklisted

PostPosted: 8:47pm, Tue 06 Mar, 2007
by pdxchuckles
I'm getting the same problem. Here's the error message:

Sorry, sending the email to request your confirmation failed, please click "Reload" to try again. If it still does not work, it may be because you are listed on our "Black List", which means that you cannot receive emails from our newsletter system. In that case, please contact the administrator.

This is a new install (version 2.10.4) on a virtual dedicated server at Godaddy. It was working fine, but stopped working a few days ago.

I searched through the forums and found that others have the same problem, but haven't seen a solution posted yet. The SMTP verification looks like an advanced function that isn't enabled in my installation (so it's not the problem in this instance).

Thanks for any help figuring this out!

Charles

PostPosted: 6:31pm, Wed 07 Mar, 2007
by LaqrHead
I too am having this problem, and SMTP is disabled.