500 Internal Server Error during ProcessQueue

Once you've installed phpList Version 2... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

500 Internal Server Error during ProcessQueue

Postby norwin » 5:59pm, Thu 08 Jul, 2010

Hi all,

Everything on my PHPList installation is working well, until I send a message. I get to ProcessQueue and after a while I receive a 500 Internal Server Error, and the following info on screen:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
--------------------------------------------------------------------------------
Apache Server at www.xxxxxxxxx.com Port 80


Once I log in again, and click through to Messages it says a number of messages have been sent. If I click on Process Queue it crashes again (to the 500 Internal Server Error) but more messages have been sent. I keep doing this until all the messages have been sent.

I'm hosting on GoDaddy, if that helps.

Thanks,
Norwin
norwin
phpLister
 
Posts: 8
Joined: 9:49am, Tue 22 Jun, 2010

Re: 500 Internal Server Error during ProcessQueue

Postby H2B2 » 8:18pm, Thu 08 Jul, 2010

norwin wrote:I'm hosting on GoDaddy, if that helps.
I wonder whether you could have broken the sendings limits of your host. Did you check sending limits?
ref: http://docs.phplist.com/PhpListConfigSendRate
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: 500 Internal Server Error during ProcessQueue

Postby Allenheathx » 8:14pm, Sat 11 Sep, 2010

I am having the exact same problem. Everything is working fine until I press the "Process queue" button. It takes me to...

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@zingtones.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


I don't think im going over my server limits because according to the "list all messages" section of phplist I've only sent 74 emails in the past 12 hours. My host limit is 200 an hour. It does appear that if I keep pressing the process queue they eventually all get out. Any one find out whats causing this issue?
Allenheathx
phpLister
 
Posts: 5
Joined: 8:01pm, Sat 11 Sep, 2010

Re: 500 Internal Server Error during ProcessQueue

Postby Allenheathx » 10:27pm, Sat 11 Sep, 2010

for the record i've deleted the entire magic line in the htaaccess file, ive created a php.ini file that sais magic_quotes_gpc = on and I re-installed the whole thing with ascII as my transfer type.

Not sure if those directions were only directed to those who couldn't access the phplist control panel entirely or not but I tried them anyway with no success. Test mails send fine, everything seems to be functioning perfectly, emails even send if i repeatedly press the processqueue button but the 500 error keeps the phplist from running automatically
Allenheathx
phpLister
 
Posts: 5
Joined: 8:01pm, Sat 11 Sep, 2010

Re: 500 Internal Server Error during ProcessQueue

Postby GazOutEast » 5:29pm, Sun 26 Sep, 2010

+1 to the list of people getting the 500 error on manual send, and random 403 errors in different locations.

I'm wondering if there's typos (mis-spelled file names etc) at odd places in the php files?
If it's fixed, I can break it
GazOutEast
PL Geek
 
Posts: 61
Joined: 4:47am, Thu 08 Apr, 2010

Re: 500 Internal Server Error during ProcessQueue

Postby H2B2 » 5:07pm, Mon 27 Sep, 2010

Allenheathx wrote:the 500 error keeps the phplist from running automatically

These threads seem to point to a timeout issue related to FastCGI:
viewtopic.php?f=24&t=19978#p77740
viewtopic.php?p=74933#p74933

You might check whether or not this applies to your server setup.
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: 500 Internal Server Error during ProcessQueue

Postby GazOutEast » 4:35am, Tue 28 Sep, 2010

Thanks H2B2 - will look into that

Regarding the 500 errors, on this particular build, the hosts confessed it was coming from their extended mod_security setup using the atomicorp suite - I did see errors in the error log naming that, but didn't make the connection.

Tip - if the error is fairly constant (repeatable) email your hosts pointing the finger at mod-security and ask them to have a look at the server logs. Any decent host will admit and offer to whitelist your domain for those errors. Make sure they only do it per domain, not per hosting account - no point opening security on other domains where it's not needed.

Gaz
If it's fixed, I can break it
GazOutEast
PL Geek
 
Posts: 61
Joined: 4:47am, Thu 08 Apr, 2010

Re: 500 Internal Server Error during ProcessQueue

Postby amed » 7:35am, Sat 01 Nov, 2014

For anyone having this problem, it seems to be an issue related to the number of messages your domain can sent. I am using plesk and enabled Outgoing Limitation Control which cause php list to give the 500 error message. I disabled Plesk Outgoing Limitation Control and phplst worked fine.

Now i Need to fine time outgoing limitation control as it's a very good security measure to fight against spammers
amed
phpList newbie
 
Posts: 3
Joined: 1:31pm, Mon 31 Jan, 2011


Return to Question & Problems - after installing

Who is online

Users browsing this forum: Google [Bot] and 4 guests