Page 1 of 1

Internal Server Error

PostPosted: 3:01pm, Sun 11 Sep, 2005
by Trinity
Hi,
I'm trying to install thephplist.
I have to admit PHP is not well known to me...
I uploaded the files as explained to public_html and configured config.php.

Now I try to get to listst/admin/ but it gives me the next error:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, (webmasters email) and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


What is the problem?

Thanks for your help...
Trin

PostPosted: 7:54pm, Wed 12 Oct, 2005
by Pemolis
I believe that particular problem has to do with the URL header.

http://www.phplist.com/forums/viewtopic.php?t=3753 (thats my problem).

My guess is that when you click on the "initialize database" button, you get the error, and your address url looks like this.

lists/admin/?page=initialise&firstinstall=1


When it SHOULD look like this.

..../lists/admin/index.php?page=initialise&firstinstall=1


Thats my present problem. The scripts keep chopping out index.php from the URL whenever I click a link. Else the program would work flawlessly.

PostPosted: 9:43pm, Tue 25 Oct, 2005
by k2par
Have the same problem, how do I fix the chopping out of INDEX.PHP, I tried editing the htaccess file, but no help. Plus I have godaddy as hosting company, let me know what I need to do.

Permissions and .htaccess

PostPosted: 4:50pm, Thu 03 Nov, 2005
by kidsport
I was getting the same errors. I installed the program through Fantastico which is provided by my hosting provider. To make the 500 Internal server errors go away they changed 2 thigns for me.

1. File permissions on all files were set to 644. Permissions on all directories were set to 755.

2. In the .htaccess files the php variable enable magic quotes gpc set to on was removed. My hosting provider runs Apache in cgi mode and the php directives in the .htaccess file will not work in that configuration.

Hope this helps you.......