"Quotes" in subject not handled properly since v.19 upgrade

Once you've installed phpList Version 2... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

"Quotes" in subject not handled properly since v.19 upgrade

Postby etienneB » 3:43pm, Thu 23 Aug, 2012

Since I upgraded to v.19, quotes in subject line are stored and sent with " instead of the " characters.

The setup is made in utf-8 and french.

The subject line is in the form of: Announcing a new event "Des artistes soutiennent l'Essentiel pour Régis".. Sending a test message return "invalid characters" which corresponds to 'errorsubject', although at that time, the message is sent properly and displayed (stored?) correctly in draft folder.
If I return later in that message to modify it, the subject looks like: Announcing a new event "Des artistes soutiennent l'Essentiel pour Régis"". . The rest of the message seems ok.

Any clue where and what to look for to fix this, which did work previously?

Etienne
etienneB
phpList newbie
 
Posts: 2
Joined: 12:39pm, Wed 22 Aug, 2012

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby duncanc » 5:09pm, Thu 23 Aug, 2012

Another poster has said that reverting to the 2.10.18 version of send_core.php avoids the problem.
http://forums.phplist.com/viewtopic.php?f=17&t=38205

In the 2.10.19 file it is the use of removeXSS() that is causing the problem. You could revert just those 6 lines that have been changed to their 2.10.18 version.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby RAYNAU » 12:03am, Fri 24 Aug, 2012

The problem is elsewhere. The problem existed in previous versions that can be configured in iso or utf-8 because it is of special characters.
RAYNAU
PL Master
 
Posts: 261
Joined: 4:32pm, Tue 03 Jan, 2012

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby duncanc » 7:26am, Fri 24 Aug, 2012

RAYNAU wrote:The problem is elsewhere. The problem existed in previous versions that can be configured in iso or utf-8 because it is of special characters.

The original poster pointed out that problem occurred after upgrading from release 2.10.18 to 2.10.19.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby etienneB » 7:39pm, Fri 24 Aug, 2012

Since my previous version was 17. I checked the send_core.php against the v18: no difference. I restore the previous version of the file and this seems to work again.

Thanks for all suggestions.
etienneB
phpList newbie
 
Posts: 2
Joined: 12:39pm, Wed 22 Aug, 2012

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby gallenkamp » 12:14am, Wed 31 Oct, 2012

Also in 2.10.19, it happens if you edit an email template. This is quite bad. So editing send_core.php is not an option in my case. I also get escaped characters in public pages which ruins my css :/
gallenkamp
phpLister
 
Posts: 6
Joined: 8:35pm, Wed 24 Oct, 2012

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby public » 6:43pm, Thu 29 Nov, 2012

Does anybody find a solution for this? I have problems in the subject with the german language on version 2.10.19.

If i e.g. want to type a "&" then in the mail it comes out as "&", not in the test-mails. In the test-mails it looks fine, although i get the message "Sorry, you used invalid characters in the Subject field."

I followed the instructions in this post:http://forums.phplist.com/viewtopic.php?f=22&t=38163
But it doesn't work for me.

In the "german.inc" file i also changed the 5th line from "ISO-8859-1" to
Code: Select all
$strCharSet             = 'utf-8';


I also created a "language_info" file with this content (as described in the post above)
Code: Select all
name=German
charset=UTF-8


I tried to change in the "languages.php" on line 26 this code
Code: Select all
"de" => array("Deutsch ","iso-8859-1","iso-8859-1, windows-1252 "),

to this
Code: Select all
"de" => array("Deutsch ","utf-8","utf-8, windows-1252 "),


All of this didn't help.
It would be so great if anybody can help.
Is it maybe something with the database?

Thank you very much in advance!
public
PL Nut
 
Posts: 15
Joined: 6:09pm, Wed 04 Nov, 2009

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby duncanc » 8:39am, Fri 30 Nov, 2012

You have been looking at the wrong files. To make phplist use the German admin interface in UTF-8 you need to modify the lanuguage_info file in the lists/admin/lan/de directory.
But you also need to follow all of the steps here
http://forums.phplist.com/viewtopic.php?f=19&t=34666
The german.inc file is in the lists/texts directory and is for the public pages - subscription etc.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby public » 12:41am, Thu 06 Dec, 2012

duncanc wrote:You have been looking at the wrong files. To make phplist use the German admin interface in UTF-8 you need to modify the lanuguage_info file in the lists/admin/lan/de directory.
But you also need to follow all of the steps here
http://forums.phplist.com/viewtopic.php?f=19&t=34666
The german.inc file is in the lists/texts directory and is for the public pages - subscription etc.

I followed the instructions as described above but it didn't help.
What am i doing wrong.

Maybe i explain it a bit ambiguous in my previous post.
I want to use phplist in english.
The only problem i have that i don't get "symbols" like "&", ü,ä in the mails.

When i write somthing like this in my subject
test & // (xxx) &
the result is
test & // (xxx) &


This problem is only when i send a newsletter, but not when i send a test message, although phplist tells me
Sorry, you used invalid characters in the Subject field.


The content of the mail itself looks fine.

Any help would be great!
Thanks
public
PL Nut
 
Posts: 15
Joined: 6:09pm, Wed 04 Nov, 2009

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby buster13 » 2:42am, Wed 12 Dec, 2012

my subject <ADV> becomes &lt;ADV&gt; when sent after .18 to .19 upgrade.

i got it solved by reverting :
In the 2.10.19 file it is the use of removeXSS() that is causing the problem. You could revert just those 6 lines that have been changed to their 2.10.18 version.
buster13
phpLister
 
Posts: 14
Joined: 8:16am, Wed 11 Aug, 2010

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby public » 11:39am, Wed 12 Dec, 2012

buster13 wrote:my subject <ADV> becomes &lt;ADV&gt; when sent after .18 to .19 upgrade.

i got it solved by reverting :
In the 2.10.19 file it is the use of removeXSS() that is causing the problem. You could revert just those 6 lines that have been changed to their 2.10.18 version.

i updated from .17 to .19 but which file do you mean exactly and where can i find it?
public
PL Nut
 
Posts: 15
Joined: 6:09pm, Wed 04 Nov, 2009

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby Dragonrider » 12:51pm, Wed 12 Dec, 2012

send_core.php as it says in the second post/first reply of this very topic. :)
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby public » 9:36pm, Mon 17 Dec, 2012

thanks to everybody for help. it worked!
public
PL Nut
 
Posts: 15
Joined: 6:09pm, Wed 04 Nov, 2009

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby mrmckoy » 8:44am, Wed 13 Feb, 2013

Could phplist release an updated 2.0.19 version with the fix in it? A lot of folks aren't seasoned admins and this may be complicated for them.
mrmckoy
PL Master
 
Posts: 169
Joined: 7:10am, Sat 24 Nov, 2007
Location: Atlanta, GA

Re: "Quotes" in subject not handled properly since v.19 upgr

Postby shayanjameel08 » 6:13am, Sat 19 Oct, 2013

Since my previous version was 17. I checked the send_core.php against the v18: no difference. I restore the previous version of the file and this seems to work again.
shayanjameel08
phpLister
 
Posts: 9
Joined: 7:49am, Sat 12 Oct, 2013


Return to Question & Problems - after installing

Who is online

Users browsing this forum: No registered users and 2 guests

cron