Page 1 of 1

"Quotes" in subject not handled properly since v.19 upgrade

PostPosted: 3:43pm, Thu 23 Aug, 2012
by etienneB
Since I upgraded to v.19, quotes in subject line are stored and sent with " instead of the " characters.

The setup is made in utf-8 and french.

The subject line is in the form of: Announcing a new event "Des artistes soutiennent l'Essentiel pour Régis".. Sending a test message return "invalid characters" which corresponds to 'errorsubject', although at that time, the message is sent properly and displayed (stored?) correctly in draft folder.
If I return later in that message to modify it, the subject looks like: Announcing a new event "Des artistes soutiennent l'Essentiel pour Régis"". . The rest of the message seems ok.

Any clue where and what to look for to fix this, which did work previously?

Etienne

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 5:09pm, Thu 23 Aug, 2012
by duncanc
Another poster has said that reverting to the 2.10.18 version of send_core.php avoids the problem.
http://forums.phplist.com/viewtopic.php?f=17&t=38205

In the 2.10.19 file it is the use of removeXSS() that is causing the problem. You could revert just those 6 lines that have been changed to their 2.10.18 version.

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 12:03am, Fri 24 Aug, 2012
by RAYNAU
The problem is elsewhere. The problem existed in previous versions that can be configured in iso or utf-8 because it is of special characters.

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 7:26am, Fri 24 Aug, 2012
by duncanc
RAYNAU wrote:The problem is elsewhere. The problem existed in previous versions that can be configured in iso or utf-8 because it is of special characters.

The original poster pointed out that problem occurred after upgrading from release 2.10.18 to 2.10.19.

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 7:39pm, Fri 24 Aug, 2012
by etienneB
Since my previous version was 17. I checked the send_core.php against the v18: no difference. I restore the previous version of the file and this seems to work again.

Thanks for all suggestions.

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 12:14am, Wed 31 Oct, 2012
by gallenkamp
Also in 2.10.19, it happens if you edit an email template. This is quite bad. So editing send_core.php is not an option in my case. I also get escaped characters in public pages which ruins my css :/

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 6:43pm, Thu 29 Nov, 2012
by public
Does anybody find a solution for this? I have problems in the subject with the german language on version 2.10.19.

If i e.g. want to type a "&" then in the mail it comes out as "&", not in the test-mails. In the test-mails it looks fine, although i get the message "Sorry, you used invalid characters in the Subject field."

I followed the instructions in this post:http://forums.phplist.com/viewtopic.php?f=22&t=38163
But it doesn't work for me.

In the "german.inc" file i also changed the 5th line from "ISO-8859-1" to
Code: Select all
$strCharSet             = 'utf-8';


I also created a "language_info" file with this content (as described in the post above)
Code: Select all
name=German
charset=UTF-8


I tried to change in the "languages.php" on line 26 this code
Code: Select all
"de" => array("Deutsch ","iso-8859-1","iso-8859-1, windows-1252 "),

to this
Code: Select all
"de" => array("Deutsch ","utf-8","utf-8, windows-1252 "),


All of this didn't help.
It would be so great if anybody can help.
Is it maybe something with the database?

Thank you very much in advance!

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 8:39am, Fri 30 Nov, 2012
by duncanc
You have been looking at the wrong files. To make phplist use the German admin interface in UTF-8 you need to modify the lanuguage_info file in the lists/admin/lan/de directory.
But you also need to follow all of the steps here
http://forums.phplist.com/viewtopic.php?f=19&t=34666
The german.inc file is in the lists/texts directory and is for the public pages - subscription etc.

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 12:41am, Thu 06 Dec, 2012
by public
duncanc wrote:You have been looking at the wrong files. To make phplist use the German admin interface in UTF-8 you need to modify the lanuguage_info file in the lists/admin/lan/de directory.
But you also need to follow all of the steps here
http://forums.phplist.com/viewtopic.php?f=19&t=34666
The german.inc file is in the lists/texts directory and is for the public pages - subscription etc.

I followed the instructions as described above but it didn't help.
What am i doing wrong.

Maybe i explain it a bit ambiguous in my previous post.
I want to use phplist in english.
The only problem i have that i don't get "symbols" like "&", ü,ä in the mails.

When i write somthing like this in my subject
test & // (xxx) &
the result is
test & // (xxx) &


This problem is only when i send a newsletter, but not when i send a test message, although phplist tells me
Sorry, you used invalid characters in the Subject field.


The content of the mail itself looks fine.

Any help would be great!
Thanks

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 2:42am, Wed 12 Dec, 2012
by buster13
my subject <ADV> becomes &lt;ADV&gt; when sent after .18 to .19 upgrade.

i got it solved by reverting :
In the 2.10.19 file it is the use of removeXSS() that is causing the problem. You could revert just those 6 lines that have been changed to their 2.10.18 version.

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 11:39am, Wed 12 Dec, 2012
by public
buster13 wrote:my subject <ADV> becomes &lt;ADV&gt; when sent after .18 to .19 upgrade.

i got it solved by reverting :
In the 2.10.19 file it is the use of removeXSS() that is causing the problem. You could revert just those 6 lines that have been changed to their 2.10.18 version.

i updated from .17 to .19 but which file do you mean exactly and where can i find it?

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 12:51pm, Wed 12 Dec, 2012
by Dragonrider
send_core.php as it says in the second post/first reply of this very topic. :)

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 9:36pm, Mon 17 Dec, 2012
by public
thanks to everybody for help. it worked!

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 8:44am, Wed 13 Feb, 2013
by mrmckoy
Could phplist release an updated 2.0.19 version with the fix in it? A lot of folks aren't seasoned admins and this may be complicated for them.

Re: "Quotes" in subject not handled properly since v.19 upgr

PostPosted: 6:13am, Sat 19 Oct, 2013
by shayanjameel08
Since my previous version was 17. I checked the send_core.php against the v18: no difference. I restore the previous version of the file and this seems to work again.