Page 1 of 1

page of sending email error

PostPosted: 9:37am, Thu 14 Aug, 2014
by rightclicklebanon
Hello,m IO ahve installed this locally on:http://localhost/phplist-2.10.19_1/lists/admin/?page=list

Till now all seems fine when I click any link such as:
http://localhost/phplist-2.10.19_1/list ... page=users ALl is normal but this page, this link:
send a message takes me to: http://localhost/lists/admin/?page=send&id=54 the phplist-2.10.19_1/ part is lost and the issue is from this class included on pages included in send.php: date.php
Which contains this keyword: On Lines 5-7:
if (!defined("IN_WEBBLER")) {
class date {
var $type = "date";
as date is a keyword
changing it to something else like date1 in this keeps the phplist-2.10.19_1/ but now the page breaks
Many Thanks

Re: page of sending email error

PostPosted: 10:34am, Thu 14 Aug, 2014
by Dragonrider
I understand why you've used such a strange path to your lists directory, though I wouldn't recommend it for on web use. Anyway, have you set the correct path on the settings page.

It's been a long time since I've used version 2, my hosts won't allow me to run such an out of date script and haven't since version 3 was originally released, so I'm going from memory. Might be worth checking the paths.

Re: page of sending email error

PostPosted: 10:38am, Thu 14 Aug, 2014
by rightclicklebanon
Hello, other pages work fine, only this page, If I am using an older version, kindly advise which version should I use

Re: page of sending email error

PostPosted: 11:20am, Thu 14 Aug, 2014
by rightclicklebanon
Hello same issue with the new version, exactly the same issue

http://localhost/lists/admin/?page=send&id=2 when I click start a new campaign other pages and links work fine:
http://localhost/phplist-3.0.6/lists/ad ... e=messages but start a new campaign simply takes to: http://localhost/lists/admin/?page=send&id=3

from other links they reach fine:
http://localhost/phplist-3.0.6/lists/ad ... e=sendthis si on from the right pane but from a link from

Re: page of sending email error

PostPosted: 11:24am, Thu 14 Aug, 2014
by rightclicklebanon
This works fine

Re: page of sending email error

PostPosted: 11:26am, Thu 14 Aug, 2014
by rightclicklebanon
It seems two parameters here produce an error that is ?par&pam2-value the &param2=value is producing the rror

Re: page of sending email error

PostPosted: 12:08pm, Thu 14 Aug, 2014
by Dragonrider
Can you please show what you have for your subscription settings please?

sub_setting.jpg
sub_setting.jpg (94.2 KiB) Viewed 14441 times

Re: page of sending email error

PostPosted: 7:22am, Mon 18 Aug, 2014
by rightclicklebanon
Hello I am very new to this framework, may you kindly advise where to find it, I search for it on settings and configurations , I am currently using: phplist-3.0.6

Re: page of sending email error

PostPosted: 8:12am, Mon 18 Aug, 2014
by Dragonrider
rightclicklebanon wrote:Hello I am very new to this framework, may you kindly advise where to find it, I search for it on settings and configurations , I am currently using: phplist-3.0.6

No problem.

In your phpList admin pages, along the top bar you should see Config, hover on that, then click on Settings.
find_settings.jpg
find_settings.jpg (45.1 KiB) Viewed 14427 times


Then a couple of "blocks" down the page, you should see the Subscription settings:
sub_setting.jpg
sub_setting.jpg (94.2 KiB) Viewed 14427 times

Re: page of sending email error

PostPosted: 9:09am, Mon 18 Aug, 2014
by rightclicklebanon
Version: phplist-3.0.6
subscription settings
edit The default subscribe page when there are multiple
1
edit URL where subscribers can sign up
http://localhost/lists/?p=subscribe
edit URL where subscribers can unsubscribe
http://localhost/lists/?p=unsubscribe
edit URL where unknown users can unsubscribe (do-not-send-list)
http://localhost/lists/?p=donotsend
edit URL where subscribers have to confirm their subscription
http://localhost/lists/?p=confirm
edit URL where subscribers can update their details
http://localhost/lists/?p=preferences
Many Thanks

Re: page of sending email error

PostPosted: 10:10am, Mon 18 Aug, 2014
by Dragonrider
Thanks for the info and image.

If you look at your image, your phpList installation is at localhost/phplist-3.0.6/lists/ yet you have localhost/lists/ as your domain in the admin config>settings page.

These all need to match. IE: you need to add /phplist-3.0.6 prior to /lists in the subscription settings.

Re: page of sending email error

PostPosted: 10:21am, Mon 18 Aug, 2014
by rightclicklebanon
Hello, Thank you, the list I updated all, but the same result but same result

IE: you need to add /phplist-3.0.6 prior to /lists in the subscription settings.
This is done but same result

Many Thanks

new.jpg
new.jpg (96.14 KiB) Viewed 14418 times

Re: page of sending email error

PostPosted: 10:32am, Mon 18 Aug, 2014
by rightclicklebanon
It is the parameter new which I changed to new1 is causing the conflict other pages work fine

This works Normal:
worksnormal.jpg
worksnormal.jpg (96.44 KiB) Viewed 14417 times


The other link breaks

<a title="start a new message x1123" href="./?page=send&amp;new1=1" class="action-button ">start a new message x1123</a>

Reached this by a redirection:
http://localhost/lists/admin/?page=send&id=46
Not Found

The requested URL /lists/admin/ was not found on this server.

Re: page of sending email error

PostPosted: 10:47am, Mon 18 Aug, 2014
by rightclicklebanon
In fact this is what is producing the scenario:
connect.php
function Redirect($page) {
if (!empty($_SERVER['HTTP_HOST'])) {
$website = $_SERVER['HTTP_HOST'];
} else {
## could check SERVER_NAME as well
$website = getConfig("website");
}

// Header("Location: ".$GLOBALS['admin_scheme']."://".$website.$GLOBALS["adminpages"]."/?page=$page");
$tryto = "".$GLOBALS['admin_scheme']."://".$website.$GLOBALS["adminpages"]."/?page=$page";

echo " this ios $website $tryto ";
// exit;
}

http://localhost/phplist-3.0.6/lists/ad ... end&new1=1


Running in testmode, no emails will be sent. Check your config file.
this ios localhost http://localhost/lists/admin/?page=send&id=49

Re: page of sending email error

PostPosted: 10:55am, Mon 18 Aug, 2014
by rightclicklebanon
OK Solved:
init.php
Line 366 369
if (!isset($pageroot)) {
$pageroot = '/lists';
$GLOBALS['pageroot'] = '/phplist-3.0.6//lists';
}
:D (y)