Page 1 of 1

test mail sending fail for no apparent reason

PostPosted: 11:01am, Mon 01 Dec, 2014
by guysh
Hello all,
I am using PHPLIST version 2.10.17. Hosted on Bluehost.
Last successful sending to the list was on October 28th.
Yesterday created a new message, sent test mail and got message
" Sent test mail to: ... failed". Mail indeed did not reach the mailbox.
PHPLIST error log file has not been changed for months,
Bluehost support saw nothing on their logs, and claim no changes were done on their server in the last month.
Any idea??
Many thanks
Guy

Re: test mail sending fail for no apparent reason

PostPosted: 11:23am, Mon 01 Dec, 2014
by duncanc
If you enable verbose in the config.php file then you might get some more information in the phplist event log.

look for
Code: Select all
define ("VERBOSE",0);

and change the 0 to 1.

Re: test mail sending fail for no apparent reason

PostPosted: 11:50am, Mon 01 Dec, 2014
by guysh
Thanks,
Tried that but no change during the send test mail phase - still same error message
and nothing on error log.
(just to make sure - error log on main phplist installation directory?)

Re: test mail sending fail for no apparent reason

PostPosted: 12:09pm, Mon 01 Dec, 2014
by duncanc
No, the phplist event log from the right hand menu.

Re: test mail sending fail for no apparent reason

PostPosted: 8:28am, Tue 02 Dec, 2014
by guysh
Thanks,
the error was "Mailer Error: Could not instantiate mail function."

But - today I tried again, changed the "from" address to the full valid email on my domain, and it worked.
I changed back the "from" address to what it was before (only user name not including @domain) and it worked as well...
There's / was something with Bluehost mailer