Request to unsubscribe non-existent user

Once you've installed phpList Version 2... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

Request to unsubscribe non-existent user

Postby Ricoshady » 5:54am, Wed 28 Feb, 2007

I have a phplist installation with about 50k emails. I ran a blast today and got lots of these errors in the event log "Request to unsubscribe non-existent user". It shows me the email address that had the problem, so I checked that against my user list and that email IS IN the system! In fact each email in the event log that had a problem is in the system, so why am I getting these errors? Why aren't people able to unsubscribe correctly? I was able to unsubscribe without a problem when I sent multiple test blasts.

Any advice would be great!

Thanks
Steve
Ricoshady
phpList newbie
 
Posts: 3
Joined: 5:47am, Wed 28 Feb, 2007

Postby michiel » 12:06am, Thu 01 Mar, 2007

if the user click on the link in the message, the check on user is not done by email address (otherwise anyone can unsubscribe anyone else) but by "uniqueid".

this is a random string that should be different for each user.

The "request to unsubscribe non existant user" means that the link that was used had a unique id (uid in the URL) that is not found in the database.

in reconcile users, there's an option to "ensure that all users have a unique id".
michiel
Admin
 
Posts: 1022
Joined: 10:18pm, Fri 11 Apr, 2003
Location: Buenos Aires, Argentina

Postby Ricoshady » 12:14am, Thu 01 Mar, 2007

That makes a lot of sense, however I did do that and it said it applied to 0 users out of 56016 users in the database. That is when I clicked "Make sure all users have unidid".

Weird huh?
Ricoshady
phpList newbie
 
Posts: 3
Joined: 5:47am, Wed 28 Feb, 2007

Postby michiel » 12:18am, Thu 01 Mar, 2007

well, you may want to check the uniqid they used when they got the error and see if it exists. It may be that eg a full stop was added to the link.
michiel
Admin
 
Posts: 1022
Joined: 10:18pm, Fri 11 Apr, 2003
Location: Buenos Aires, Argentina

Postby Ricoshady » 2:06am, Thu 01 Mar, 2007

I got a hold of an email that was sent out, I checked for the uniqid in the link against the database. The email and id matched up. When I follow the link from the browser it says "Error User not found".

I'd post the link but the forum won't let me. but if I cut and paste the link into the browser that doesnt work either. HEre is what is very odd, in the event long it tells me the email address that could not unsubscribe, which tells me the look up was atleast made since the unsubscribe link does not send the email address. Aswell, the link to account preferences does work.
Ricoshady
phpList newbie
 
Posts: 3
Joined: 5:47am, Wed 28 Feb, 2007

Postby michiel » 3:06am, Thu 01 Mar, 2007

sorry, then I have no idea. Sounds rather odd. If you think it's a bug, try to investigate it and post an issue to mantis. It might be something peculiar with your situation.
michiel
Admin
 
Posts: 1022
Joined: 10:18pm, Fri 11 Apr, 2003
Location: Buenos Aires, Argentina


Return to Question & Problems - after installing

Who is online

Users browsing this forum: No registered users and 6 guests