Internal Server Error

Once you've installed phpList Version 2... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

Internal Server Error

Postby kunal247 » 2:12pm, Mon 02 Apr, 2007

Hi,
I have a PHP List working for last one year.
Lately when some once completes the subscribe page they are seeing an error.

~~~~~~~~~~~~~~~~~~~~~
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, my@email.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
~~~~~~~~~~~~~~~~~~~~~

Not sure why this is happeneing.
I do get there confirmation of them scbcribing to the list coming to me on an email as I am the administrator.

How can I correct this error.
Please help!!

Kunal :idea:
kunal247
PL Nut
 
Posts: 42
Joined: 6:06pm, Wed 02 Nov, 2005

Postby Hernol » 1:55pm, Tue 24 Apr, 2007

This is not a bug, just remove the php_magic_gpc flag of the .htaccess in the lists directory.
Hernol
Admin
 
Posts: 1378
Joined: 6:39pm, Thu 18 May, 2006
Location: Argentina

Postby kunal247 » 9:46am, Thu 26 Apr, 2007

My original .htaccess file:
Code: Select all
DirectoryIndex index.php

<FilesMatch>
Order allow,deny
deny from all
</FilesMatch>
<FilesMatch>
Order allow,deny
allow from all
</FilesMatch>
<FilesMatch>
Order allow,deny
allow from all
</FilesMatch>
php_flag magic_quotes_gpc on


I have removed
Code: Select all
php_flag magic_quotes_gpc on

As suggested.

new .htaccess file:
Code: Select all
DirectoryIndex index.php

<FilesMatch>
Order allow,deny
deny from all
</FilesMatch>
<FilesMatch>
Order allow,deny
allow from all
</FilesMatch>
<FilesMatch>
Order allow,deny
allow from all
</FilesMatch>


Still getting the same error.

Please help, what is going wrong!!!

Kunal :idea:
kunal247
PL Nut
 
Posts: 42
Joined: 6:06pm, Wed 02 Nov, 2005

Postby kunal247 » 10:41am, Thu 26 Apr, 2007

I have also now tried:
Code: Select all
#php_flag magic_quotes_gpc on

And also deleting the line completely.

Hope some one can help.
This is rather urgent need to fix.

Kunal :!:
kunal247
PL Nut
 
Posts: 42
Joined: 6:06pm, Wed 02 Nov, 2005

Quick Fix

Postby Tki2000 » 11:00am, Tue 08 May, 2007

There are troubles with .htaccess files in phplist and Apache configurations if your Apache is not configured with "AllowOverride All" in "htt_pd.conf" file (take away the _).
Another configuration I found working is "AllowOverride Options AuthConfig Indexes Limit" but this is only possible if you have access to the Apache server config file and this is probably not possible.

A quick FIX is to TAKE AWAY the .htaccess files in dirs "/lists" and "/admin" (and probably in any other dir where .htaccess may reside), but it will open some security related issues. If this is the case, try to use the .htaccess files to authenticate the users that may have access to files and not to deny the files.
Tki2000
phpList newbie
 
Posts: 4
Joined: 2:34pm, Sat 18 Nov, 2006


Return to Question & Problems - after installing

Who is online

Users browsing this forum: No registered users and 4 guests