Incredible Throttle setting issue

Once you've installed phpList Version 2... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

Incredible Throttle setting issue

Postby Chandan13 » 3:57am, Fri 20 Apr, 2007

Hi,

What must be wrong in this code:

define("MAILQUEUE_BATCH_SIZE",50);
define("MAILQUEUE_BATCH_PERIOD",1800);
define('MAILQUEUE_THROTTLE',6);

Considering that my server allows me to send just 100 messages a day (not an hour), I am trying to set to send 50 messages per 30 minutes with a difference of 6 seconds for each mail.

All that I get is this for more than an hour:

Started
Sending in batches of 50 emails
Processing has started, 1 message(s) to process.
Please leave this window open.
You have batch processing enabled, so it will reload several times to send
the messages. Reports will be sent by email to admin
Processing message 42
Looking for users
Found them: 100 to process

And this continues...

I do get a message in my admin mail box saying that 50 messages have been sent, though I sent 100. but the batch processing keeps going on and on.

Please advice,

Chandan
Chandan13
phpLister
 
Posts: 9
Joined: 4:50pm, Tue 10 Apr, 2007
Location: New Castle, UK

Re: Incredible Throttle setting issue

Postby H2B2 » 2:55pm, Fri 20 Apr, 2007

Chandan13 wrote:Considering that my server allows me to send just 100 messages a day (not an hour), I am trying to set to send 50 messages per 30 minutes with a difference of 6 seconds for each mail.
Never seen message limits as stringent as this. I would suggest you look for another hosting company.

As it is, your current settings would result in trouble with your providers's message limits, if you need to process more than 100 messages.

To avoid the issue of breaking the message limits set by your ISP, you would need to use these settings:
Code: Select all
define("MAILQUEUE_BATCH_SIZE",100); # msg limit per day
define("MAILQUEUE_BATCH_PERIOD",86400); #equals 24 hours
define('MAILQUEUE_THROTTLE',6);

The problem with a batch period of 24 hours is that it is likely to result in a timeout, which is probably the cause of your current trouble.

In order to reduce the chances of a timeout occuring, you could lower the batch period to 15 minutes, i.e. send 1 message every 15 minutes, which would equal to 96 messages in 24 hours:
Code: Select all
define("MAILQUEUE_BATCH_SIZE",1); # msg limit per 15 mnts
define("MAILQUEUE_BATCH_PERIOD",900); #equals 15 minutes
define('MAILQUEUE_THROTTLE',4);


An alternative would be to avoid using the batch period, and just space the messages so that no more than 100 messages are being sent every 24 hours by solely using the mailqueue_throttle setting.
Code: Select all
define("MAILQUEUE_BATCH_SIZE",0); # batch processing disabled
define("MAILQUEUE_BATCH_PERIOD",3600); # not effective
define('MAILQUEUE_THROTTLE',900); # pause 15 mnts between msgs


All this doesn't seem very practical. Hence my advice: look for another host.
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006


Return to Question & Problems - after installing

Who is online

Users browsing this forum: No registered users and 5 guests

cron