Mailer Error: Could not instantiate mail function.

Once you've installed phpList Version 2... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

Mailer Error: Could not instantiate mail function.

Postby cormanaz » 2:45pm, Fri 20 Apr, 2007

Greetings. I've got phplist set up. It sends test messages just fine, and it even sent messages to some users on my one list about a week ago. When I tried to send another message yesterday I discovered that it did not send the first message to everyone. When I processed the queue again with the new message, I get two messages for every address for both messages
Code: Select all
Error sending message 7 to someone@someplace.com (someone@someplace.com)
followed by
Code: Select all
Mailer Error: Could not instantiate mail function.


Per some posts I found on this forum, I set throttle to 1. No help. Another post says the second message may indicate my ISP is blocking php sendmail function. I'm checking, but if that were the case the test messages wouldn't work, which they do.

Does anyone know how I can debug this?

Thanks......Steve
cormanaz
phpList newbie
 
Posts: 1
Joined: 2:26pm, Fri 20 Apr, 2007

Postby H2B2 » 1:57pm, Sun 22 Apr, 2007

You could take a look at this bug report: http://mantis.phplist.com/view.php?id=8590
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

I am having the same problem

Postby supersnow » 7:53pm, Sun 06 May, 2007

Hi there I am going crazy over this.

I first had the problem of trying to work out which of the dozen cron job solutions would work on my hosting server. Finally worked with
Code: Select all
lynx -dump 'http://www.mydomain.com/lists/admin/index.php?page=processqueue&login=user&password=password' >/dev/null


And it seemed to be working. Then I started seeing the the number left to be sent was not going down but the number sent out was still climbing . I have a list around 7500:

6474 still to process

but on the right hand side it says
5670 sent

So I looked at my eventlog and found the same prolem as above

Code: Select all
Error sending message 27 to somone@someplace.com (somone@someplace.com)
Mailer Error: Could not instantiate mail function.


And I have tried the solution on the debug area:
http://mantis.phplist.com/view.php?id=8590

but nothing has changed. I still getting the mailer error.

My hosting server has the following:

Operating system Linux
Kernel version 2.6.19-1_3.BHsmp
Apache version 1.3.37 (Unix)
PERL version 5.8.7
Path to PERL /usr/bin/perl
Path to sendmail /usr/sbin/sendmail
PHP version 4.4.6
MySQL version 4.1.21-standard-log
cPanel Build 10.9.0-RELEASE 7965

The phplist version I am running is 2.10.4

I really need help I can't even send out using the manual process queue now.

I have contacted my host my they have just suggested that I need to reduce the batch size etc. which by the way I tried too! But nothing has worked - help help help!!!!

:?
supersnow
phpList newbie
 
Posts: 3
Joined: 7:27pm, Sun 06 May, 2007


Return to Question & Problems - after installing

Who is online

Users browsing this forum: Google [Bot] and 7 guests