Error 405 while Creating Custom Subscribe Form

Once you've installed phpList Version 2... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

Error 405 while Creating Custom Subscribe Form

Postby fazd » 2:07am, Sat 21 Apr, 2007

There was a post on this same prob and a link was submitted on how to fix it but the link no longer works.




I am creating custom subscription forms but when I try to view them I get the error 405 page.
fazd
phpList newbie
 
Posts: 1
Joined: 2:01am, Sat 21 Apr, 2007

Postby H2B2 » 1:28pm, Sun 22 Apr, 2007

One possible cause for this error 405 - "Method not allowed" is that index.html takes precedence over index.php as the default page in your mailing list directory.

This can be fixed by making index.php the default page, as describe in the throubleshooting documentation:
Error: please make sure that index.php is your default document for a directory. If you have just installed PHPlist and get this message, make sure that the DirectoryIndex setting of your Apache configuration has somewhere index.php index.html, and check that index.php is mentioned before index.html. For other webservers please consult your manual to find how to make index.php the default document for a directory. Alternatively you can delete the file "index.html" in the lists directory of PHPlist.

Source: http://docs.phplist.com/PhplistTroubleshooting
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006


Return to Question & Problems - after installing

Who is online

Users browsing this forum: No registered users and 6 guests