Sent emails do not match configuration specified

Once you've installed phpList Version 2... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

Sent emails do not match configuration specified

Postby jimnee » 6:31pm, Sat 21 Apr, 2007

Hi folks,

I'm having trouble with PHPList sending 'text' emails when each and every user is listed as 'html' and when I create the message I also specify to only send html, no text.

I just sent an email to a client's list of 92 people. Each user is "1" for html and I specified "html only" when I sent it. Yet when I look at the stats, 41 text emails were sent and 51 html emails.

My client is freaking out because he received one of the text versions and considers it 'unreadable'. How do I stop this? Why is it happening? If it helps, the url I copy/pasted from into the email is a newsletter from my client is http://www.annapoliscollegeministry.org ... /07/04.php (of course, I used absolute urls in the email itself). Is there something in the coding that would cause PHPList to say, 'nah, I'm not going to send that as an html email..."?

Any thoughts would be great.

Many thanks.
jimnee
phpLister
 
Posts: 10
Joined: 6:25pm, Sat 21 Apr, 2007

Postby H2B2 » 2:28pm, Sun 22 Apr, 2007

- Please provide some info on your server setup: type/versions of: OS, PHP, mySQL, phplist, etc.
- Have you enabled any experimental features in config.php?
- Have you enabled SMTP in config.php?
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby jimnee » 7:20pm, Sun 22 Apr, 2007

H2B2 wrote:- Please provide some info on your server setup: type/versions of: OS, PHP, mySQL, phplist, etc.
- Have you enabled any experimental features in config.php?
- Have you enabled SMTP in config.php?


Hi Al,

Thanks for getting back to me. My STMP settings in the config file are:

# To use a SMTP please give your server hostname here, leave it blank to use the standard
# PHP mail() command.
define("PHPMAILERHOST",'');

# if you want to use smtp authentication when sending the email uncomment the following
# two lines and set the username and password to be the correct ones
#$phpmailer_smtpuser = 'smtpuser';
#$phpmailer_smtppassword = 'smtppassword';

I haven't enable any experimental features. My server info is:

Linux cl02 2.6.20.2-1 #4
PHP 4
mySQL (not entirely sure, but my host's info is here: http://www.mediatemple.net/webhosting/g ... ainers.htm )
PHPList version 2.10.4

Hope that helps!
jimnee
phpLister
 
Posts: 10
Joined: 6:25pm, Sat 21 Apr, 2007

Postby H2B2 » 8:59pm, Sun 22 Apr, 2007

Hard to say what is causing this, and whether it's server related or not. That's why it might be relevant to know your server setup. According to your provider's site they offer "Up-to-date and secure versions of PHP 4 and 5 with MySQL 4.1.11".
You could check this page to get some more specific info: http://www.yourdomain.com/lists/admin/?page=info

Apparently you are not using SMPT at the moment. Could you enable SMPT in config.php and see if that makes any difference? For SMTP to work, you will also need to apply this bug fix: http://mantis.phplist.com/view.php?id=8590
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006


Return to Question & Problems - after installing

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron