Page 1 of 1

Email 'from' field

PostPosted: 12:08pm, Fri 27 Apr, 2007
by muppet
No matter what I try (reading the help '?' hints when creating a newlsetter) I don't get anything other than the domain as the 'from' and 'reply to' address.

What am I doing wrong?

I've tried all three versions (one word, two words, zero/more words) but all emails have this as from address;

"thedcorporation.com [wv06gj39@web01.ahp.ftl.affinity.com]"

(thedcorporation.com = DOMAIN)

PostPosted: 11:26pm, Fri 27 Apr, 2007
by H2B2
I suppose you are aware of these settings
On the configuration page:
- From email address for system messages
- From name for system messages
- Reply-to email address for system messages

In config.php:
Code: Select all
# admin details for messages
# since ver. 2.10.3 if this is enabled phplist will initialise the From in new messages to be the
# details of the logged in administrator who is sending the message
# otherwise it will default to the values set in the configure page that identify
# the From for system messages
define('USE_ADMIN_DETAILS_FOR_MESSAGES',1);

In my install these settings are also automatically used for the from name/email address in list messages. However a number of users reported having trouble with changing the from email address. Not sure what could cause this, but my best guess is that this issue could be related to the way the (mail)server has been configured by a particular host.

You might check whether enabling or disabling the above mentioned setting in config.php makes any difference for you.

If not, than you might take a look at these threads and see it those can help you fix the problem:
- http://forums.phplist.com/viewtopic.php?p=23259
- http://forums.phplist.com/viewtopic.php?=&p=27197
- http://forums.phplist.com/viewtopic.php?t=9146
Or search the forum and bug tracker more thouroughly than I did.

not sorted yet

PostPosted: 4:59pm, Sat 28 Apr, 2007
by muppet
I have followed all this, tried all as well .. to no avail. The newsletter are still sent with the details given before, even ones sent from a new admin user with totally different emails and domains specified.

The details in the from/reply field are the same, no matter what I type into the field in the messgae boxes, and what is in the user fields.

PostPosted: 9:07am, Fri 04 May, 2007
by muppet
Still no change. All emails coem with the from details of:

name[hosting_company_username-AT-hosting_company_details]

I've tried with different admin acocunts I've set up, I've read and re-read laods of posts here and nothing. What would I need to ask the hosting company to find out what their settings are doing to over-ride the PHPList ones?

PostPosted: 3:32am, Wed 09 May, 2007
by bombay
Hmmmm... did you try this format in your "from: line?

[YOUR NAME HERE] <email>


That should work...

PostPosted: 7:48am, Wed 09 May, 2007
by muppet
I'll give it a go, let you know if it works.

PostPosted: 7:56am, Wed 09 May, 2007
by muppet
nope, still coming up with same details.