Cannot Display Page and magic_quotes_gpc Problems

Once you've installed phpList Version 2... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

Cannot Display Page and magic_quotes_gpc Problems

Postby jenangel » 4:28pm, Tue 01 May, 2007

My PHPList was working fine until my server host moved my site to a new server on Sunday. The IP of the site changed and it also went from /home2 to /home. I changed this over in my config.php file. Everything seemed to be back up and running, although I had not tested anything yet. I noticed first off that now it says "Warning: Things will work better when PHP magic_quotes_gpc = on". I followed the instructions and added the file '/lists/php.ini' with the following code
Code: Select all
magic_quotes_gpc = 1
. I did not add anything else. I saved it and uploaded it. It did not help as I am still getting the same message.

PROBLEM 2 - I also noticed that not everything is working now. I have not tested anything else as of yet, but I went in to reconsile users and it will not let me do anything. When I try to merge or delete users it takes me basically a blank page that says "Internet Explorer cannot display the webpage". This didn't happen before the server move. Any suggestions on fixing these 2 problems?

Sincerely,
Jen
jenangel
phpLister
 
Posts: 8
Joined: 4:44am, Sun 11 Mar, 2007

Postby jenangel » 5:45pm, Thu 03 May, 2007

I just wanted to bump the topic to see if anyone can help. Thank you!

Jen
jenangel
phpLister
 
Posts: 8
Joined: 4:44am, Sun 11 Mar, 2007

Postby H2B2 » 12:16am, Fri 04 May, 2007

This seems to be a server related issue. Have you contacted your host and discussed the problem with them?
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby jenangel » 2:07pm, Fri 04 May, 2007

I tried about the magic quotes. They just told me the php.ini file is there. :roll:

When my host moved me to a new server it changed my site from being on a /home2 server to a /home server. I have found some of the places where this needed to be changed in the editing. I also ended up having to turn off the fck editor. It helped a little, but not too much. When I sent out my newsletter and processed queue it thought about it then went to a blank page, not going to the processing page as it normally would. The odds are there is just more coding that needs to be edited, but I'm not sure where.

Is it possible to backup my 2 mailing lists and the people on them, delete the current phplist, and reinstall it, then import the subscribers? It seems this might almost be the better way to go at this point.
jenangel
phpLister
 
Posts: 8
Joined: 4:44am, Sun 11 Mar, 2007

Postby H2B2 » 2:42pm, Fri 04 May, 2007

You can make a full backup (including the user lists) of the database as described here: http://docs.phplist.com/BackupDatabase

I would suggest you try a separate install of phplist in a separate directory and with a separate database and see if that works, before deleting your current installation.
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006


Return to Question & Problems - after installing

Who is online

Users browsing this forum: Majestic-12 [Bot] and 7 guests