Page 1 of 1

Debugging PHPList Problem with SMTP

PostPosted: 2:45pm, Sat 19 May, 2007
by ezeala
I really need help at my wits end with this.

Trying to run PHPList using SMTP. When I try sending a test message from the "Send A Message" page.
nothing gets sent out I've checked both the inbox and the bulk folder of the receiveing email account.
but looking at the log of events there no error messages.

How can I turn on finer level debbuging to see whats actually going on with the SMTP connection. Any help would be highly appreciated.

Log of Events

42 del processqueue 2007-05-19 07:24:54 Sending via smtp

41 del processqueue 2007-05-19 07:24:54 Sending authenticated email via smtp.mail.yahoo.com

40 del processqueue 2007-05-19 07:24:54 Found them: 1 to process

39 del processqueue 2007-05-19 07:24:54 Looking for users

38 del processqueue 2007-05-19 07:24:54 Processing message 28

37 del processqueue 2007-05-19 07:24:54 Your webserver is running in "safe_mode". Please keep this window open. It may reload several times to make sure all messages are sent. Reports will be sent by email to listreports@mywebsite.com

36 del processqueue 2007-05-19 07:24:54 Processing has started, 1 message(s) to process.



Config.php

# If you want to use the PHPMailer class from phpmailer.sourceforge.net, set the following
# to 1. If you tend to send out html emails, it is recommended to do so.
define("PHPMAILER",1);

# To use a SMTP please give your server hostname here, leave it blank to use the standard
# PHP mail() command.
define("PHPMAILERHOST",'smtp.mail.yahoo.com');

# if you want to use smtp authentication when sending the email uncomment the following
# two lines and set the username and password to be the correct ones
$phpmailer_smtpuser = 'myid';
$phpmailer_smtppassword = 'mypassword';</div>

Re: Debugging PHPList Problem with SMTP

PostPosted: 11:23pm, Sat 19 May, 2007
by H2B2
When using SMTP you should be aware of this bug report: http://mantis.phplist.com/view.php?id=8590

As for a higher SMTP debug level, you might try playing with this in /lists/admin/phpmailer/class.phpmailer.php
Code: Select all
    /**
     *  Sets SMTP class debugging on or off.
     *  @var bool
     */
    var $SMTPDebug    = false;
Ref: http://phpmailer.sourceforge.net/docs/e ... ailer.html