[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4758: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3893)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4760: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3893)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4761: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3893)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4762: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3893)
phplist forums • View topic - [fixed] v2.10.10: After upgrade cannot create new message

[fixed] v2.10.10: After upgrade cannot create new message

Discuss, research, share, find, and solve bugs

[fixed] v2.10.10: After upgrade cannot create new message

Postby woolef » 4:04pm, Thu 07 May, 2009

Went from 2.10.9 to 2.10.10. All seems fine except when I go to create message or edit an old message I just get the tabs along the top of the edit pane (content/format/scheduling etc) but nothing below these. The footer is missing off the bottom too. This happens in FF3, IE7 and Chrome. I can still see the full edit window if I use my old install of 2.10.9 to view. I've attached a screen shot of what I can see.
Attachments
phplist_message_error.jpg
phplist_message_error.jpg (45.69 KiB) Viewed 20734 times
woolef
PL Nut
 
Posts: 21
Joined: 10:40pm, Tue 17 Feb, 2009

Re: [V2.10.10] After upgrade can not create a new message

Postby H2B2 » 4:09pm, Thu 07 May, 2009

Seems related to this thread viewtopic.php?p=61854#p61854

Did you try the solution proposed by primebus? See viewtopic.php?p=30998#p30998
phpList | | | |
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: [V2.10.10] After upgrade can not create a new message

Postby woolef » 4:31pm, Thu 07 May, 2009

Thanks H2B2.

I hadn't seen that actually (wood for trees) but now I've tried what was suggested it still isn't working (I've changed it back again now). I'm running php 5.2.6 and MySQL5.0.51b if that's any help.
woolef
PL Nut
 
Posts: 21
Joined: 10:40pm, Tue 17 Feb, 2009

Re: [V2.10.10] After upgrade can not create a new message

Postby H2B2 » 4:55pm, Thu 07 May, 2009

FCKeditor on v2.10.10 works fine for me with PHP 5.2.3, so I don't think the PHP version is causing this issue. A PHP setting might possibly be the culprit. In earlier versions the problem was often caused by ASP tags being enabled in php.ini. It should be set to asp_tags = Off

You might check that too.
Ref: viewtopic.php?p=48237#p48237
phpList | | | |
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: [V2.10.10] After upgrade can not create a new message

Postby woolef » 6:00pm, Thu 07 May, 2009

Thanks, I'll get in touch with my host to see what it's set to.

Isn't it a bit strange that 2.10.9 works fine (and still does now) but 2.10.10 doesn't?
woolef
PL Nut
 
Posts: 21
Joined: 10:40pm, Tue 17 Feb, 2009

Re: [V2.10.10] After upgrade can not create a new message

Postby woolef » 6:13pm, Thu 07 May, 2009

asp_tags is set to off
woolef
PL Nut
 
Posts: 21
Joined: 10:40pm, Tue 17 Feb, 2009

Re: [V2.10.10] After upgrade can not create a new message

Postby H2B2 » 8:45pm, Thu 07 May, 2009

phpList | | | |
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: [V2.10.10] After upgrade can not create a new message

Postby taydeko » 5:03pm, Sun 10 May, 2009

I found a solution to the same problem I was having. None of the other fixes worked. The issue was in the Send_Core.php file. On lines 1023 and 1024 of my version you will find:

// value="'.htmlentities($subject,ENT_QUOTES,'UTF-8').'" size=40></td></tr> --> previous code in line 1032
// value="'.htmlentities($from,ENT_QUOTES,'UTF-8').'" size=40></td></tr> --> previous code in line 1038

On line 1034 and 1040 are:

//value="'.htmlentities(iconv('ISO-8859-1','UTF-8',$subject),ENT_QUOTES,'UTF-8').'" size=40></td></tr>
value="'.htmlentities(iconv('ISO-8859-1','UTF-8',$from),ENT_QUOTES,'UTF-8').'" size=40></td></tr>

I am not sure why 1034 is commented out, but if you replace 1034 with the contents of 1023 without the comment, and replace 1040 with 1024 without the comment, the program works fine for me. So it looks like something is causing a problem in the "iconv('ISO-8859-1','UTF-8',$from)" bit of code.

So the resulting code starting at line 1030 looks like this:

$maincontent .= '
<tr><td>'.Help("subject").' '.$GLOBALS['I18N']->get("Subject").':</td>
<td><input type=text name="msgsubject"
value="'.htmlentities($subject,ENT_QUOTES,'UTF-8').'" size=40></td></tr>
<tr>
<td colspan=2>
</td></tr>
<tr><td>'.Help("from").' '.$GLOBALS['I18N']->get("fromline").':</td>
<td><input type=text name=from
value="'.htmlentities($from,ENT_QUOTES,'UTF-8').'" size=40></td></tr>
<tr><td colspan=2>
</td></tr>';

Someone who knows a lot more about the program and php would have to fix the problem with iconv or explain why it is better, but for now this works.

Ted
taydeko
phpLister
 
Posts: 12
Joined: 9:59pm, Sat 09 May, 2009

Re: [V2.10.10] After upgrade can not create a new message

Postby H2B2 » 12:07am, Mon 11 May, 2009

phpList | | | |
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: [V2.10.10] After upgrade can not create a new message

Postby woolef » 9:31am, Mon 11 May, 2009

Brilliant Ted & H2B2, many thanks to you both! That's fixed my FCKeditor window.

My encoding follows;

character_set_client: utf8
character_set_connection: utf8
character_set_database: latin1
character_set_filesystem: binary
character_set_results: utf8
character_set_server: latin1
character_set_system: utf8
woolef
PL Nut
 
Posts: 21
Joined: 10:40pm, Tue 17 Feb, 2009

Re: [fixed] v2.10.10: After upgrade cannot create new message

Postby H2B2 » 1:40am, Wed 13 May, 2009

phpList | | | |
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: [fixed] v2.10.10: After upgrade cannot create new message

Postby woolef » 8:57am, Wed 13 May, 2009

Sorry, not for me. I changed my file back to original and uncommented 1034 but got the same result. ie. just tabs, no editor.

I then changed the individual lines by substituting first one, reverting, then substituting the second. My editor window would not reappear until I had substituted both 1034 and 1040.

Hope that makes sense :/
woolef
PL Nut
 
Posts: 21
Joined: 10:40pm, Tue 17 Feb, 2009

Re: [fixed] v2.10.10: After upgrade cannot create new message

Postby H2B2 » 2:10pm, Wed 13 May, 2009

Thanks for the feedback. Could you view (in your web browser) the HTML source code of one of your admin pages and check which charset encoding is used as "Content-Type", like for instance:
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
phpList | | | |
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Re: [fixed] v2.10.10: After upgrade cannot create new message

Postby eweriuer » 9:52pm, Wed 13 May, 2009

eweriuer
phpLister
 
Posts: 11
Joined: 9:18pm, Wed 13 May, 2009

Re: [fixed] v2.10.10: After upgrade cannot create new message

Postby H2B2 » 7:07pm, Thu 14 May, 2009

phpList | | | |
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Next

Return to Bug Discussion

Who is online

Users browsing this forum: No registered users and 0 guests