404 Error on Wordpress /lists and lists/admin

Questions & Problems about Installing or Upgrading Version 2 phpList
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation. This is for Version 2 of phpList (the orange one).

404 Error on Wordpress /lists and lists/admin

Postby essent » 6:40am, Mon 30 May, 2011

Hi,

I've followed all the steps and changed the config file etc but when I try to go to /lists I get a 404 error. I have checked the permissions as per another thread and double checked I have the ;'s and ".s in the config file. Any help greatly appreciated :)
essent
phpList newbie
 
Posts: 1
Joined: 6:22am, Mon 30 May, 2011

Re: 404 Error on Wordpress /lists and lists/admin

Postby Dragonrider » 8:25am, Mon 30 May, 2011

The problem here was that your sever did not like the line: php_flag magic_quotes_gpc on in the lists/.htaccess file, adding the "#" to the line thus: #php_flag magic_quotes_gpc on and reasaving your .htaccess file, fixed the error.

Your error trapping in your main site's .htaccess file trapped the 500 error which was caused by the magic_quotes setting, and you were redirected to your 404 error page.

Make the change, save the file, and issue sorted.
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: 404 Error on Wordpress /lists and lists/admin

Postby ubaid12j » 2:01pm, Thu 28 Jun, 2012

You just remove your htaccess file, but remember to keep backup of your .htaccess file.
Now go to admin section and deactivate permalinks option. After doing this you logout.
So again login and activate the permalinks option, after this an .htaccess file will automatically created.
And there will be no problem of 404 error.
Kind Regards!

______________________________________________________________
blogger templates 2012 - blogger templates - themeforest
ubaid12j
phpList newbie
 
Posts: 1
Joined: 1:58pm, Thu 28 Jun, 2012

Re: 404 Error on Wordpress /lists and lists/admin

Postby leosampieri » 1:44am, Mon 09 Jul, 2012

Hi, everyone.
I'm getting the same error, that's why I'm posting here. Hope I'm doing right.
I've been trying to setup phplist on the same host as a wordpress installation: www.belgranostudio.com.ar,
but when I try to initiate it in http://www.belgranostudio.com.ar/lists/admin/, I get the error. You can see it for yourselves.
Have you managed to solve this?

Thanks in advance!.
Leo.
leosampieri
phpList newbie
 
Posts: 2
Joined: 1:39am, Mon 09 Jul, 2012

Re: 404 Error on Wordpress /lists and lists/admin

Postby leosampieri » 1:50am, Mon 09 Jul, 2012

Hi again!
I've managed to sort it out.
I had to comment out the last line of the htaccess file.
THX!
leosampieri
phpList newbie
 
Posts: 2
Joined: 1:39am, Mon 09 Jul, 2012

Re: 404 Error on Wordpress /lists and lists/admin

Postby gpowerhost » 12:09pm, Wed 06 Nov, 2013

This can occur when one app situated in a directory below uses a Rewrite Engine to control the error process, as WordPress does. It frequently happens when the phplist (or an other app) has a password protected directory. Apache's implementation of Password Protection utilizes a call to an error 401 (Unauthorized) as part of the authorization process. This process get hijacked (by in this case WordPress) and the authorization has no chance of occurring. Since many have Password protection enabled as possibly the admin directory or one of its files, and they long since authorized their computer, folks often forget that this is a factor.

In this case, a solution is not to alter your WordPress .htaccess, but to use the root phplist's .htaccess (not the list/admin/.htaccess, but list/.htaccess) to regain control. Adding the following as necessarily the first statement in your .htaccess should do the trick:
Code: Select all
#Added line below to prevent WP from hijacking the URL in the Authorization Process
ErrorDocument 401 default


This is a common problem and I thought it worth bumping a rather old post as it is still an issue I see several times a month.

Hope this helps!
gpowerhost
phpList newbie
 
Posts: 1
Joined: 3:28am, Wed 06 Nov, 2013


Return to Installing & Upgrading

Who is online

Users browsing this forum: No registered users and 2 guests