Page 2 of 2

Re: SOLVED Cron user must now be a superuser; Send not happe

PostPosted: 6:54pm, Sun 01 Sep, 2013
by Sven2157
Try this:
Code: Select all
/usr/local/cpanel/3rdparty/bin/php -q /home/user/public_html/phplist/admin/index.php -p processqueue -c /home/user/public_html/phplist/config/config.php > /home/user/public_html/phplist/processqueue.log 2>&1

There should be a space between config.php, the carrat( > ) and /home/.

See if that works.

Sven2157

Re: SOLVED Cron user must now be a superuser; Send not happe

PostPosted: 7:07pm, Sun 01 Sep, 2013
by geminorum
OK, I tried and the processqueue.log is:

Code: Select all
phpList version 3.0.2 (c) 2000-2013 phpList Ltd, http://www.phplist.com
PHPlist - Recently sent : 0
PHPlist - Started [0.0026650000] (85)
PHPlist - Sending in batches of 190 emails [0.0003300000] (86)
PHPlist - Script stage: 6 [0.0006450000] (89)
PHPlist - Finished, Nothing to do [0.0001580000] (90)
PHPlist - Finished, All done [0.0003530000] (93)


But no email was received (sent to a test list with yahoo, gmail and other accounts. No mail received).

Thanks!

Re: SOLVED Cron user must now be a superuser; Send not happe

PostPosted: 7:36pm, Sun 01 Sep, 2013
by Sven2157
geminorum wrote:OK, I tried and the processqueue.log is:

Code: Select all
phpList version 3.0.2 (c) 2000-2013 phpList Ltd, http://www.phplist.com
PHPlist - Recently sent : 0
PHPlist - Started [0.0026650000] (85)
PHPlist - Sending in batches of 190 emails [0.0003300000] (86)
PHPlist - Script stage: 6 [0.0006450000] (89)
PHPlist - Finished, Nothing to do [0.0001580000] (90)
PHPlist - Finished, All done [0.0003530000] (93)


But no email was received (sent to a test list with yahoo, gmail and other accounts. No mail received).

Thanks!

No worries ... 8)

Try making a new list, with JUST you on it. Then set your cron to send that list.

I suspect that the cron is programmed to ignore everything, while in TEST mode; as there is no user interface, to see when it is running a script process.

Sven2157

Re: SOLVED Cron user must now be a superuser; Send not happe

PostPosted: 8:01pm, Sun 01 Sep, 2013
by geminorum
With this command:
Code: Select all
*/10 *   * * *   /usr/local/cpanel/3rdparty/bin/php -q /home/user/public_html/phplist/admin/index.php -pprocessqueue -c /home/user/public_html/phplist/config/config.php > /home/user/public_html/phplist/processqueue.log 2>&1


it works!

now, the processqueue.log says:

Code: Select all
phpList version 3.0.2 (c) 2000-2013 phpList Ltd, http://www.phplist.com
PHPlist - Recently sent : 0
PHPlist - Started [0.0027000000] (85)
PHPlist - Sending in batches of 190 emails [0.0003240000] (86)
PHPlist - Processing has started, 1 message(s) to process. [0.0006080000] (90)
PHPlist - Processing message 17 [0.1758590000] (114)
PHPlist - Looking for subscribers [0.0007600000] (119)
PHPlist - Found them: 4 to process [0.0018460000] (125)
PHPlist - Processing batch of: 4 [0.0008420000] (129)
PHPlist - sent 1 ETA Sun 1 Sep 22:58 sending 4158 msg/hr
PHPlist - sent 2 ETA Sun 1 Sep 22:58 sending 4796 msg/hr
PHPlist - sent 3 ETA Sun 1 Sep 22:58 sending 4955 msg/hr
PHPlist - sent 4 ETA Sun 1 Sep 22:58 sending 5170 msg/hr
PHPlist - Processed 4 out of 4 subscribers [2.6032780000] (220)
PHPlist - It took  03 seconds to send this message [0.1454650000] (233)
PHPlist - Script stage: 5 [0.0012400000] (239)
PHPlist - 4 messages sent in 2.93 seconds (4909 msgs/hr) [0.0006280000] (242)
PHPlist - Finished this run [0.0005390000] (246)

Re: SOLVED Cron user must now be a superuser; Send not happe

PostPosted: 8:16pm, Sun 01 Sep, 2013
by Sven2157
So it was your time setting? or Test mode? or Both? I didn't realize you hadn't set a time to it. :|

Glad you got it working though! :wink:

Sven2157

Re: SOLVED Cron user must now be a superuser; Send not happe

PostPosted: 8:32pm, Sun 01 Sep, 2013
by geminorum
I guess there was two errors:

time setting was
Code: Select all
10 * * * *
instead of
Code: Select all
*/10 * * * *

and inside the line

Code: Select all
index.php -p processqueue
instead of
Code: Select all
index.php -pprocessqueue


:) Thanks.

Re: SOLVED Cron user must now be a superuser; Send not happe

PostPosted: 7:51pm, Sun 03 Nov, 2013
by glassmaker
[i]
geminorum wrote:and inside the line

Code: Select all
index.php -p processqueue
instead of
Code: Select all
index.php -pprocessqueue


:) Thanks.


I was having problems after upgrading to 3.02 and found this thread which helped me get things working again. (The problem was needing to add the path of the config file to the cron script. Thank you, duncanc.)

But I tested the script using both "-p processqueue" and "-pprocessqueue" and it seemed to work using either one. Is there a specific reason to change this?

Re: SOLVED Cron user must now be a superuser; Send not happe

PostPosted: 7:47pm, Wed 17 Dec, 2014
by valicas
geminorum's solition totaly worked. Tnx!