Page 1 of 1

error 404 on link

PostPosted: 2:39pm, Wed 14 May, 2014
by mulbzh
Hello,

i had installed phplist 3.0.6
I put all the files in http://www.domain.fr/newsletter/

when i am in administration interface, if i click on one link, i have got error 404 (not found), for all link it is the same error :?

If i look in URL, i can see : http://www.domain.fr/newsletter/admin/?page=home
but if i change this URL to http://www.domain.fr/newsletter/admin/index.php?page=home, it works !

but i have to always put index.php in URL for it work....

I had change in config.php something, i put $pageroot as $pageroot = '/newsletter';

but it is not better !
any ideas ?

thanks

Re: error 404 on link

PostPosted: 4:37pm, Wed 14 May, 2014
by danwaterloo
It sounds like you need to tell apache to recognize the index.php file as a default page to display

you can do that using a .htaccess file, put it in your lists directory...
this content works for me... should work for you....

Code: Select all
DirectoryIndex index.php

<FilesMatch "\.(php|inc)$">
Order allow,deny
deny from all
</FilesMatch>
<FilesMatch "(index.php|dl.php|ut.php|lt.php|download.php|connector.php)$">
Order allow,deny
allow from all
</FilesMatch>

# if you want more than this for attachments, you can increase these values
# but you really, really should consider uploading them somewhere
# and only sending a link in your mails
# bigger than this really doesn't make sense in emails

## these lines are now commented out, to avoid 500 errors, https://mantis.phplist.com/view.php?id=9937
## but you should consider adding them

#php_value upload_max_filesize 3M
#php_value post_max_size 4M

Re: error 404 on link

PostPosted: 9:28am, Thu 15 May, 2014
by mulbzh
hello,

i look in .htaccess in my newsletter directory and it is already like this :(

Re: error 404 on link

PostPosted: 10:10am, Thu 15 May, 2014
by Dragonrider
If you've set your $pageroot in the config.php file (not config-extended.php which needs to be renamed config.php to work), then can you please check your admin pages for config>Settings and look at your Subscription settings and ensure that the URL's shown there are correct for your path to your newsletter directory, no extra "/" or missing or extra directories given.

If that's correct, please see if removing the / from the start of your $pageroot="/newsletter"; makes any difference. Then get back to us.

Re: error 404 on link

PostPosted: 12:18pm, Thu 15 May, 2014
by mulbzh
i had changed Subscription settings with correct URL but the problem is still the same.

i had changed $pageroot but not better.

I think the problem is about htaccees.
I had installed Phplist in www.domain.fr/newsletter but there is one other website in www.domain.fr with one other htacess

# AUTH
AuthName "Restricted Area"
AuthType Basic
AuthUserFile /var/www/vhosts/domain.fr/subdomains/ysm/httpdocs/.htpasswd
AuthGroupFile /dev/null
#require valid-user

# URL REWRITING
Options +FollowSymlinks
RewriteEngine on

RewriteCond %{HTTP_HOST} !www.domain.fr$
RewriteRule (.*) http://www.domain.fr/$1 [R=301,L]

RewriteRule ^([0-9]{1,3})(-[a-z0-9-_]+)?/?$ index.php?id=$1 [L,QSA,NC]
RewriteRule ^([a-z0-9-_]+)/?$ index.php?section=$1 [L,QSA,NC]
RewriteRule ^([a-z0-9-_]+)/([0-9]{1,3})(-[a-z0-9-_]+)?/?$ index.php?section=$1&$
RewriteRule ^([a-z0-9-_]+)/([0-9]{4})/?$ index.php?section=$1&year=$2 [L,QSA,NC]
RewriteRule ^([a-z0-9-_]+)/([0-9]{4})/([0-9]{2})/?$ index.php?section=$1&year=$$
RewriteRule ^([a-z0-9-_]+)/([0-9]{4})/([0-9]{2})/([0-9]{1,3})(-[a-z0-9-_]+)?/?$$
RewriteRule ^([a-z0-9-_]+)/([a-z0-9-_]+)/?$ index.php?section=$1&page=$2 [L,QSA$
RewriteRule ^([a-z0-9-_]+)/([a-z0-9-_]+)/([a-z-]+)/?$ index.php?section=$1&page$
RewriteRule ^([a-z0-9-_]+)/([a-z0-9-_]+)/([0-9]{1,3})(-[a-z0-9-_]+)?/?$ index.p$
RewriteRule ^([a-z0-9-_]+)/([a-z0-9-_]+)/([a-z-]+)/([0-9]{1,3})(-[a-z0-9-_]+)?/$

# RESIZE
RewriteRule ^medias/thumb/(.*)$ php/resize3.php?width=auto&height=120&max_width$
RewriteRule ^medias/square/(.*)$ php/resize3.php?width=150&height=150&method=cr$
#RewriteRule ^medias/original/(.*)$ medias/domain.fr/medias/$1 [L,NC,QSA,NE]

# GZIP
AddType application/x-httpd-php .php .htm .html
php_flag zlib.output_compression On
php_value zlib.output_compression_level 9

# ETAG
FileETag none

# MIN : MINIFY + GZIP + EXPIRES (CSS + JS)
RewriteRule ^(js|css)/([0-9.]+)/([a-z0-9]+).(js|css)$ /min/?g=$3.$4&v=$2

# DIRECTORY INDEX
DirectoryIndex index.php



do you think is the problem ?

Re: error 404 on link

PostPosted: 6:54am, Tue 20 May, 2014
by mulbzh
no idea ?