phplist[3.0.7] getting Fatal Error Mysql is not supported.

Questions & Problems about Installing or Upgrading with Version 3 phpList.
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

phplist[3.0.7] getting Fatal Error Mysql is not supported.

Postby Mwanajeshi » 3:14pm, Sun 24 Aug, 2014

Hello,
I have downloaded phplist 3.0.7 and upload it to my host and it gave me this error

Fatal Error: Mysql is not supported in your PHP, recompile and try again.
I tried using Softaculous and it gave me the same error.
my environment
Apache 2.2.27
PHP 5.4.31
MySQL 5.5.37
Servers are running Linux 2.6.32
I have checked the config file over and over nothing came out of that.
Need you help guys.
Mwanajeshi
phpList newbie
 
Posts: 1
Joined: 2:39pm, Sun 24 Aug, 2014

Re: phplist[3.0.7] getting Fatal Error Mysql is not support

Postby Dragonrider » 8:13am, Mon 25 Aug, 2014

Ah! Found it!

Depreciation of mysql from PHP5.5 onwards. Change to mysqli or comment out the config.php line 687

Code: Select all
$database_module = "mysqli.inc";

OR

Code: Select all
#$database_module = "mysql.inc";
solves the issue

Normally, when you update your phpList to 3.0.7 you are informed that your database is out of date, when you click on the link to update it, you get a message about mysqli and a link to the above page that explains why and how to solve. As you didn't get that far, you didn't see the link to change to mysqli.

Just amend your config/config.php file to either of the above options.
config vs config-extended
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: phplist[3.0.7] getting Fatal Error Mysql is not support

Postby ciberpata » 8:39pm, Mon 22 Sep, 2014

Hi
I get "Fatal Error: Mysql is not supported in your PHP, recompile and try again"
In post I see the possible solution and I changed line mysql.inc (687) from config.php but nothing.
Is the same error in upgrades from 3.05 to 3.08.
My php version is 5.4.3 and MySQL version is 5.5.

Somebody would yo help me pz?

Thanks
ciberpata
phpLister
 
Posts: 8
Joined: 11:37am, Mon 07 Oct, 2013

Re: phplist[3.0.7] getting Fatal Error Mysql is not support

Postby Dragonrider » 7:19am, Tue 23 Sep, 2014

If you have done as instructed without success, try removing the mysql.inc line completely and restart phpList in a fresh browser window.
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: phplist[3.0.7] getting Fatal Error Mysql is not support

Postby ciberpata » 4:34pm, Tue 23 Sep, 2014

Hi,
I delete the line indicated, but I get the same error.

Thanks
ciberpata
phpLister
 
Posts: 8
Joined: 11:37am, Mon 07 Oct, 2013

Re: phplist[3.0.7] getting Fatal Error Mysql is not support

Postby Dragonrider » 5:13pm, Tue 23 Sep, 2014

You ARE using the full config-extended.php file that you renamed to config.php ?

If you are, all I can suggest is to re-install phpList 3.0.8 in case some files are either missing or corrupt.
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom


Return to Installing and Upgrading

Who is online

Users browsing this forum: No registered users and 1 guest