Blank page on install with changed and original config.php

Questions & Problems about Installing or Upgrading with Version 3 phpList.
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Re: Blank page on install with changed and original config.p

Postby danwaterloo » 2:50pm, Wed 10 Sep, 2014

perhaps your web server isn't setup properly?
can you make one of the 'phpinfo' files, and see if it displays anything? if not, your apache web server needs php support turned on.
http://kb.mediatemple.net/questions/764 ... page%3F#gs
danwaterloo
PL Master
 
Posts: 276
Joined: 3:51am, Wed 30 Oct, 2013
Location: http://www.phplistsupport.com

Re: Blank page on install with changed and original config.p

Postby danwaterloo » 2:52pm, Wed 10 Sep, 2014

i use centos, and the selinux configuration is in /etc/sysconfig/selinux ...

here's what mine shows:
Code: Select all
cat /etc/sysconfig/selinux
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#       enforcing - SELinux security policy is enforced.
#       permissive - SELinux prints warnings instead of enforcing.
#       disabled - SELinux is fully disabled.
SELINUX=disabled
# SELINUXTYPE= type of policy in use. Possible values are:
#       targeted - Only targeted network daemons are protected.
#       strict - Full SELinux protection.
SELINUXTYPE=targeted

# SETLOCALDEFS= Check local definition changes
SETLOCALDEFS=0


being on a shared host, you might not be able to get to it.
danwaterloo
PL Master
 
Posts: 276
Joined: 3:51am, Wed 30 Oct, 2013
Location: http://www.phplistsupport.com

Re: Blank page on install with changed and original config.p

Postby sostberg » 3:16pm, Wed 10 Sep, 2014

You are right, I don't get to this /etc/sysconfig... Again this says "No such file or directory".
PHPinfo works. It says PHP-version 5.4.32 and a lot more. Shall I look for some special information?
sostberg
phpLister
 
Posts: 13
Joined: 9:00am, Thu 04 Sep, 2014

Re: Blank page on install with changed and original config.p

Postby danwaterloo » 2:55am, Thu 11 Sep, 2014

no, that's ok.
1. so you have installed a brand new version, moving the 'lists' directory of the unzipped new version into the root folder of the website? and you should get a page that says it cannot connect to the database.

2. Then you created an empty database, and a database user/password, and then gave that user rights to connect to the database. (You should check that the user has permissions to read/write/edit, etc... the database.) (You need to do this in the cpanel/plesk interface to your hosted system).

3. Then you should put that database name, database user, database user password into the config.php file (the one that came with the brand new download.)

4. Then you should go to the /lists/admin page, and the system should complain that the database doesn't have any data, and you click the 'initialize database' (or whatever the exact wording is), and it should initialize all the tables, etc. in the database, and bring you to the config page.

Do these steps in sequence, and let me know which one fails...
danwaterloo
PL Master
 
Posts: 276
Joined: 3:51am, Wed 30 Oct, 2013
Location: http://www.phplistsupport.com

Re: Blank page on install with changed and original config.p

Postby sostberg » 1:26pm, Wed 17 Sep, 2014

Sorry, I've been very busy during the last days...

So, here is what I achieved:
1. Done, complains about missing database connection

2. Empty new database created. Unfortunately I'm not allowed to grant permissions, but what I read online is that 1&1 automatically gives you all the permissions you usually need. I checked it by the command "show grants;" and this is the result:
1 GRANT USAGE ON *.* to 'database user'@'%' IDENTIFIED BY PASSWORD 'password'
2 GRANT ALL PRIVILEGES ON 'database'.* TO 'database user'@'%'
'database' and 'database user' are the values that were created by 1&1, to ones I use. 'Password' is a long phrase of numbers and letters I never created. When I use this as the passwort in config.php, I get the error message that the password is wrong. So, obviously I should have all rights granted...

3. Done, but this still leads to the blank page without any code.

4. Not possible.

By the way: I now used PHPlist 3.0.8
sostberg
phpLister
 
Posts: 13
Joined: 9:00am, Thu 04 Sep, 2014

Re: Blank page on install with changed and original config.p

Postby sostberg » 1:55pm, Mon 22 Sep, 2014

Does anyone have any ideas?
sostberg
phpLister
 
Posts: 13
Joined: 9:00am, Thu 04 Sep, 2014

Re: Blank page on install with changed and original config.p

Postby Dragonrider » 3:45pm, Mon 22 Sep, 2014

sostberg wrote:Does anyone have any ideas?

Can you please confirm that you have filled in the required values for:

The database_Host, (What is this?)
The Database_Name, (what is this?)
The Database_User, (what is this?)
The Database Password. (do NOT give this).

Thanks
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Blank page on install with changed and original config.p

Postby LastMohikkan » 2:45pm, Thu 09 Oct, 2014

Sadly I've got the same problems on my localhost (mamp server) ...
I also tried the troubleshooting from this thread, but all in all it ends again in a blank page, after I get to the initialize database link.
(phplist 3.0.8 version, PHP Version 5.5.14, MySQL Version: 5.5.38)


Anyone any ideas?
LastMohikkan
phpList newbie
 
Posts: 1
Joined: 11:04am, Thu 09 Oct, 2014

Re: Blank page on install with changed and original config.p

Postby danwaterloo » 1:44am, Tue 14 Oct, 2014

I'd probably try to look at things one at a time...

for the database, use some kind of graphical tool, and make sure it exists, etc. it is probably ok because the software seems to know about it.

many times a blank page is caused by a missing character or two in the config.php file. you'll want to check that closely, maybe you can put a 'fresh' copy of the config.php file in your system, edit only the database name, the database user, and the database user password. that should do enough to have the system turn on.

if you still get a blank page, you should look at your apache log files, system message log, etc. it could be that you are missing a package or two (php) that the software needs.

good luck! this all boils down to 'basic' troubleshooting techniques, which on a linux box is mostly looking at the various log files, copy and paste errors into google.
danwaterloo
PL Master
 
Posts: 276
Joined: 3:51am, Wed 30 Oct, 2013
Location: http://www.phplistsupport.com

Re: Blank page on install with changed and original config.p

Postby sostberg » 2:20pm, Tue 14 Oct, 2014

Dragonrider wrote:Can you please confirm that you have filled in the required values for:

The database_Host, (What is this?)
The Database_Name, (what is this?)
The Database_User, (what is this?)
The Database Password. (do NOT give this).

Thanks

Please excuse my late reply, as I was very busy...
Host: db544049---.db.1and1.com
Name: db544049---
User: dbo544049---
All information is filled in, including passwort.
sostberg
phpLister
 
Posts: 13
Joined: 9:00am, Thu 04 Sep, 2014

Previous

Return to Installing and Upgrading

Who is online

Users browsing this forum: No registered users and 1 guest

cron