Blank page on Install

Questions & Problems about Installing or Upgrading with Version 3 phpList.
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Blank page on Install

Postby vetriolo » 6:03pm, Thu 11 Sep, 2014

Hello everyboby,
I'm facing the following problem trying to install version 3.0.7 or 3.0.8 on a windows server 2008 hosting (on an italian hosting, Aruba).
On server there is php 5.2.14 and Mysql 5.5.38-35.2
Without any change I clearly get the connection database error.
Then I alter the config.php with the correct connection values, paying attention on semicolor and brackets, and after that of the admin/index.php I get only the header without any link for the database creation.
I have also tried to change all directories to be read/execute and write, but nothing has changed.

Any suggestion where it could be the problem ??
vetriolo
phpLister
 
Posts: 5
Joined: 2:33pm, Thu 11 Sep, 2014

Re: Blank page on Install

Postby Dragonrider » 8:25pm, Sat 13 Sep, 2014

Can you confirm where you have your list installed please?

EG: domain/lists or what?

In config.php what is the value in $pageroot?

In the above example, this line should be: $pageroot="/lists";
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Blank page on Install

Postby vetriolo » 2:48pm, Mon 15 Sep, 2014

Hi,

the installation has been done in domain/lists and $pageroot value is:

$pageroot="/lists";

Hopinng you can have a good suggestion !
vetriolo
phpLister
 
Posts: 5
Joined: 2:33pm, Thu 11 Sep, 2014

Re: Blank page on Install

Postby Dragonrider » 4:22pm, Mon 15 Sep, 2014

vetriolo wrote:Hi,

the installation has been done in domain/lists and $pageroot value is:

$pageroot="/lists";

Hopinng you can have a good suggestion !

That's okay.

Now, have you still got a blank page or what message are you seeing now please?

An image would be quite helpful.
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Blank page on Install

Postby vetriolo » 5:09pm, Tue 16 Sep, 2014

Still a blank page with only the header.
Here comes a sreenshot.
In the html after the </head> this is ALL what the page contains:
++++++++++++++++
<body class="home">
<div id="dialog"></div><div id="hiddendiv"></div>

<div id="container" class="container_24 container">
<div id="header" class="grid_24 sixteen columns">
<div id="logo"><a href="http://www.phplist.com" target="_blank"><img src="ui/dressprow/images/branding.png" alt="phpList, email newsletter manager, logo" title="phpList, the world's most popular Open Source newsletter manager" /></a></div>
<div id="logged">
<a id="logout" href="./?page=logout">Logout</a> </div>
</div>
<!-- end .grid_24 -->
<div class="clear"></div>
<div id="navigation" class="grid_24 sixteen columns">
<div id="main-menu" class=" fourteen columns alpha">
</div>
<div class="two columns omega">
<span id="menu-button"><span>Menu</span></span>
</div>
</div>
<div id="globalhelp">
</div>
<div class="clear"></div>
<div id="content" class="grid_20 twelve columns">
<div id="wrapp">
<div id="progressbar"></div>
<!-- content start here -->
++++++++++++++++++++

No more after this !!!!!
:(
Attachments
ScreenShot1.jpg
ScreenShot1.jpg (43.83 KiB) Viewed 11410 times
vetriolo
phpLister
 
Posts: 5
Joined: 2:33pm, Thu 11 Sep, 2014

Re: Blank page on Install

Postby Dragonrider » 5:25pm, Tue 16 Sep, 2014

That's your admin page, what do you get on the public page? ie: domain.com/lists

If you'd be willing to let me have a look at your site, could you PM me with the actual URL please?
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Blank page on Install

Postby vetriolo » 7:13am, Wed 17 Sep, 2014

Hi,
this is very simple: as I have been not able to start the database table creation, I simply get a db error.

I enclose also the screenshot of domain/lists.
Attachments
ScreenShot2.jpg
ScreenShot2.jpg (66.72 KiB) Viewed 11397 times
vetriolo
phpLister
 
Posts: 5
Joined: 2:33pm, Thu 11 Sep, 2014

Re: Blank page on Install

Postby Dragonrider » 7:34am, Wed 17 Sep, 2014

That's normal, however you should have found a fix database link when you first visit your lists/admin page. As that has not appeared, I would suggest you re-install phpList as there could be some files missing or corrupted.
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Blank page on Install

Postby vetriolo » 8:35am, Wed 17 Sep, 2014

Hi again,
but this is exactly the point !
this is a fresh install !!
If you see the first post I have explained this.
In any case to try I have deleted all the "lists" folder and reinstalled a fresh download from phplist web site.
Doing nothing in the lists/admin page I clearly get:
"Cannot connect to Database, please check your configuration"
Then simply changing the 4 values for database connection in config.php I get the blank page already posted !!
Also adding "$pageroot = '/lists';" does not change anything.

I do not know what to do !!

Is not that the server is missing some php module needed ??
Or as there is php version 5.2.14, is this enough ???
vetriolo
phpLister
 
Posts: 5
Joined: 2:33pm, Thu 11 Sep, 2014

Re: Blank page on Install

Postby Dragonrider » 9:14am, Wed 17 Sep, 2014

vetriolo wrote:Or as there is php version 5.2.14, is this enough ???


Just having checked out the System Requirements for phpList 3.0.8, that's a No. phpList version 3.0.8 requires at least PHP 5.3.x

You can always check the System Requirements page from the link on the Downloads page.
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Blank page on Install

Postby ido » 8:46pm, Tue 21 Oct, 2014

Hi,

i have the exact problem.

i started a vm with a clean centos 6.4, disabled selinux
yum install httpd php php-mysql mysql-server php-imap

set mysql root password.
create database phplist;

wget http://.../phplist-3.0.9.zip
unzip phplist-3.0.9.zip
cp -Rf public_html /var/www/html

then set the config.php file with db user root and root pass and DB phplist.

then went to http://ip/lists/admin


and i got the exact problem, only header without the ability to install.

then i removed the mysql + php from the server, and installed php 5.5 and mysql 5.5.
still exactly the same error...

this is the removing and new php\mysql install:
160 rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm
161 yum install mysql55w mysql55w-server
162 yum remove mysql-libs
163 yum install mysql55w mysql55w-server
174 yum search php-mysql
175 yum remove php
176 yum search php
177 yum install php55w
178 yum remove php-common
179 yum install php55w
180 yum install php55w-imap
183 yum install php55w-mysqli


i restarted my http every change... (no, this is not the problem...)
the /lists/ works as expected with DB eror...

i checked the error log and the phplist vsite error log and nothing there.
i set display errors and log errors on in php.ini file. and still nothing.
the respond stops here : "<!-- content start here -->"
so i guess it's an include or something like that (@file_get_content that the server cant find)...

if you want ssh access to the server please pm me...

Thanks,
ido
ido
phpList newbie
 
Posts: 2
Joined: 8:32pm, Tue 21 Oct, 2014

Re: Blank page on Install

Postby ido » 11:32am, Wed 22 Oct, 2014

YAAAAAAAAHHHHHHH!!!!!!!

found it!!!!!

session.save_path = "/tmp"
in php.ini

i guess it didnt have a write perms on the default folder...
ido
phpList newbie
 
Posts: 2
Joined: 8:32pm, Tue 21 Oct, 2014

Re: Blank page on Install

Postby Dragonrider » 12:05pm, Wed 22 Oct, 2014

ido wrote:YAAAAAAAAHHHHHHH!!!!!!!

found it!!!!!

session.save_path = "/tmp"
in php.ini

i guess it didnt have a write perms on the default folder...

That's good news, thanks for letting us know.
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Blank page on Install

Postby yog900050 » 7:48pm, Wed 29 Oct, 2014

Hi everyone,

I have exactly the same problem with a new centos 6 virtual machine install.

Can you let me know what you did to resolve the problem?

I'm thinking either comment out or change that line in the php.ini file, or change the permissions for the folder it mentions - but I'm not sure on the consequences of either.

What's the best course of action to get this fixed?

Cheers,
Al.
yog900050
phpList newbie
 
Posts: 1
Joined: 5:27pm, Wed 29 Oct, 2014

Re: Blank page on Install

Postby acirillo » 4:41pm, Mon 17 Nov, 2014

Same problem..Centos on VPS, PHPList installed via Softacolous, db is ok, front end in ok (subscribe n unsubscribe), magic quote off, php5, mysql and mysqli extension, WTF!? :?
When I go to mydomain.it/lists/admin the page is blank...i have tried to reupload a fresh copy of config.php (tried also with config_extended.php renamed in config.php), but the issue remain.

Image

PHPList 3.0.10
Apache 2.2.29
PHP 5.3
MySQL 5
acirillo
phpList newbie
 
Posts: 1
Joined: 4:32pm, Mon 17 Nov, 2014

Next

Return to Installing and Upgrading

Who is online

Users browsing this forum: No registered users and 1 guest