path and quoting problems[SOLVED]

Questions & Problems about Installing or Upgrading with Version 3 phpList.
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

path and quoting problems[SOLVED]

Postby nienberg » 9:48pm, Mon 20 Oct, 2014

I upgraded from 2.x to 3.0.9. I installed into a directory named "eLists". My admin pages work fine, but the pages seen by subscribers look awful. There seems to be two issues. First, the paths to images are incorrect. They are missing the "eLists" directory. They are specified as if the "images" directory is in the server root.

Second, there is a quoting issue (backslashes are added before double quotes). You can easily see the problem here.

http://mail.tippingstructural.com/eLists/?p=subscribe

Thanks for any suggestions.
Last edited by nienberg on 6:49pm, Wed 22 Oct, 2014, edited 1 time in total.
nienberg
phpList newbie
 
Posts: 3
Joined: 9:38pm, Mon 20 Oct, 2014

Re: path and quoting problems

Postby duncanc » 12:42pm, Tue 21 Oct, 2014

The quote problem has been introduced in release 3.0.9 and should be fixed imminently.
I think that problem may also causing your images not to appear. The phplist images directory is specified relative to the phplist directory, not as a full path. For example
Code: Select all
 src="images/TMlogo.png"
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: path and quoting problems

Postby nienberg » 4:24am, Wed 22 Oct, 2014

After some more testing I agree with you that the problem is just due to the quoting and is not a path issue. Where should I look for the fix and how will I know when it has been issued?

Thanks very much for your help,
nienberg
phpList newbie
 
Posts: 3
Joined: 9:38pm, Mon 20 Oct, 2014

Re: path and quoting problems

Postby duncanc » 6:42am, Wed 22 Oct, 2014

Release 3.0.10 is now available through the Download link at the top of each forum page.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: path and quoting problems [SOLVED]

Postby nienberg » 6:48pm, Wed 22 Oct, 2014

I upgraded to 3.0.10 and confirm that this solved the problem.

Thanks,
nienberg
phpList newbie
 
Posts: 3
Joined: 9:38pm, Mon 20 Oct, 2014


Return to Installing and Upgrading

Who is online

Users browsing this forum: No registered users and 4 guests