Mysql is not supported in your PHP, recompile and try again.

Questions & Problems about Installing or Upgrading with Version 3 phpList.
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Mysql is not supported in your PHP, recompile and try again.

Postby jon2jay » 7:15am, Sat 08 Nov, 2014

Ahhhh Please help.

php -v
PHP 5.4.34 (cli)

# mysql -v
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 83624
Server version: 5.5.40-cll MySQL Community Server (GPL)


upon going to /lists/admin I receive the error:
Mysql is not supported in your PHP, recompile and try again.



PHP INFO:


mysql
MySQL Support enabled
Active Persistent Links 0
Active Links 0
Client API version 5.5.40
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib64 -lmysqlclient

Directive Local Value Master Value
mysql.allow_local_infile On On
mysql.allow_persistent On On
mysql.connect_timeout 60 60
mysql.default_host no value no value
mysql.default_password no value no value
mysql.default_port no value no value
mysql.default_socket /var/lib/mysql/mysql.sock /var/lib/mysql/mysql.sock
mysql.default_user no value no value
mysql.max_links Unlimited Unlimited
mysql.max_persistent Unlimited Unlimited
mysql.trace_mode Off Off

mysqlnd
mysqlnd enabled
Version mysqlnd 5.0.10 - 20111026 - $Id: c85105d7c6f7d70d609bb4c000257868a40840ab $
Compression supported
SSL supported
Command buffer size 4096
Read buffer size 32768
Read timeout 31536000
Collecting statistics Yes
Collecting memory statistics No
Tracing n/a
Loaded plugins mysqlnd,example,debug_trace,auth_plugin_mysql_native_password,auth_plugin_mysql_clear_password
API Extensions pdo_mysql


PDO
PDO support enabled
PDO drivers sqlite, mysql

pdo_mysql
PDO Driver for MySQL enabled
Client API version mysqlnd 5.0.10 - 20111026 - $Id: c85105d7c6f7d70d609bb4c000257868a40840ab $

Directive Local Value Master Value
pdo_mysql.default_socket /var/lib/mysql/mysql.sock /var/lib/mysql/mysql.sock

pdo_sqlite
PDO Driver for SQLite 3.x enabled
SQLite Library 3.7.7.1
jon2jay
phpList newbie
 
Posts: 1
Joined: 7:10am, Sat 08 Nov, 2014

Re: Mysql is not supported in your PHP, recompile and try ag

Postby Dragonrider » 10:53am, Sat 08 Nov, 2014

My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom


Return to Installing and Upgrading

Who is online

Users browsing this forum: No registered users and 2 guests

cron