Installing v3.0.10 in different directory

Questions & Problems about Installing or Upgrading with Version 3 phpList.
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Installing v3.0.10 in different directory

Postby freigei » 9:30am, Sun 28 Dec, 2014

Hello,

since I was flooded with unwanted accesses to the standard dierectory (http://www.mysite.com/lists/admin/) I choose to install it in a different directory (such as http://www.mysite.com/_lists/admin/ to block "bots" from accessing.
However, PHPlist seems to "insist" on directory "/lists" on some pages: I can log-in, view liste and subscribers, but when changing an data I get a "file not found" error for requesting a page at http://www.mysite.com/lists/admin/... (i.e. it requests the "standard" diectory).
Any recommendations to handle this? Thanks for any hint in advance!
Helmut
freigei
phpList newbie
 
Posts: 2
Joined: 9:19am, Sun 28 Dec, 2014

Re: Installing v3.0.10 in different directory

Postby Dragonrider » 9:54am, Sun 28 Dec, 2014

Either edit or add $pageroot="/_lists"; to your config.php file

That should help, if it does not like the underscore ("_") change the name to something else and ensure the directory matches this new name.

Alternatively see if your cPanel/Plesk admin offers .htpasswd as an option and password protect the lists/admin directory.

A possible option is to add /admin to your robots.txt file under the Disallow section.
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Installing v3.0.10 in different directory

Postby freigei » 12:27pm, Mon 29 Dec, 2014

Thank you very much, drangonrider!

Your advice is very welcome and profound!
Have a fun new-year's eve and a wonderful new year!
Helmut
freigei
phpList newbie
 
Posts: 2
Joined: 9:19am, Sun 28 Dec, 2014

Re: Installing v3.0.10 in different directory

Postby Dragonrider » 1:02pm, Mon 29 Dec, 2014

freigei wrote:Thank you very much, drangonrider!

Your advice is very welcome and profound!
Have a fun new-year's eve and a wonderful new year!
Helmut

No problem, have a great one yourself. :)
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom


Return to Installing and Upgrading

Who is online

Users browsing this forum: No registered users and 1 guest