Page 1 of 1

instaling problem. Blank page or Syntax error

PostPosted: 2:33pm, Tue 24 Feb, 2015
by OverKilL13
i'm tried to instal phpList on 2 different domains.
at first i tried to install in a different place, after problems i tried to make default install on second domain.
i'm make a base config, i would tell about second try, cuz not to much params:

$database_host = "xxx.mysql";
$database_name = "xxx_xxx";
$database_user = "xxx_xxx";
$database_password = 'xxxxx';

and i had a blank page, after enable a "$error_level = error_reporting(E_PARSE)"
i have got this message

Parse error: syntax error, unexpected T_VARIABLE in /home/proba/proba.nichost.ru/docs/mail/config/config.php on line 21

the line 21 is : $database_host = "xxx.mysql";
with "localhost" it not works too. I'm already have some expirience with databases.

can this be a problem because of dot in a middle of $database_host = "xxx.mysql"; ???
and what can i do with it?) Another programms works fine with this dot in a middle...

firefox - 36
phpList - 3.0.12
php 5.2
mySQL via TCP/IP - 5.1.41

Re: instaling problem. Blank page or Syntax error

PostPosted: 3:39pm, Tue 24 Feb, 2015
by duncanc
Possibly there is something wrong with the preceding line?

Re: instaling problem. Blank page or Syntax error

PostPosted: 6:24am, Wed 25 Feb, 2015
by OverKilL13
duncanc wrote:Possibly there is something wrong with the preceding line?

this is the preceding line) i just miss this in messege. This is the first important line if not talking about error report line

Re: instaling problem. Blank page or Syntax error

PostPosted: 10:01am, Wed 25 Feb, 2015
by danwaterloo
The database_host tells phpList where the database is located.
phpList needs the following to fully specify how to connect to the database:
host, user, password

it sounds like phpList cannot locate your host.
can you ping 'xxx.mysql' (from the command line of the phpList installation)?

here are a couple of settings that I have seen... none have '.mysql' on the end....

in this example, the mysql database is on the same host as the phpList installation:
Code: Select all
# what is your Mysql database server
$database_host = "localhost";


in this example, the mysql database is on 192.168.0.95, which is available over the LAN interface on the phpList machine(the phpList machine had two interfaces, one for the LAN and one for the WAN):
Code: Select all
# what is your Mysql database server
$database_host = "192.168.0.95";

Re: instaling problem. Blank page or Syntax error

PostPosted: 10:12am, Wed 25 Feb, 2015
by Dragonrider
Parse error: syntax error, unexpected T_VARIABLE in /home/proba/proba.nichost.ru/docs/mail/config/config.php on line 21


Could you please show us your config file, lines 16 through to 29, hide your private data by all means, but please show us all the lines around that area. Cheers

Default code: lines 16-29
Code: Select all
*/

# what is your Mysql database server hostname
$database_host = "localhost";

# what is the name of the database we are using
$database_name = "phplistdb";

# what user has access to this database
$database_user = "phplist";

# and what is the password to login to control the database
$database_password = 'phplist';



Also, as you have installed in a non-default directory (mail, not lists) can you confirm what setting you have for $pageroot please.

Doing a Google search for nichost.ru database settings, I note that userid.mysql is the way you access phpMyAdmin, but is that the actual database NAME you are using for the database for phpList?

Re: instaling problem. Blank page or Syntax error

PostPosted: 1:39pm, Wed 25 Feb, 2015
by OverKilL13
for default directory
Code: Select all
*/

# what is your Mysql database server hostname
$database_host = "xxxx.mysql";

# what is the name of the database we are using
$database_name = "xxxx_mail";

# what user has access to this database
$database_user = "xxxx_mysql";

# and what is the password to login to control the database
$database_password = 'xxxxxxx';

for non-default directory
Code: Select all
*/
# what is your Mysql database server hostname
$database_host = "xxxx.mysql";

# what is the name of the database we are using
$database_name = "xxxx_mail";

# what user has access to this database
$database_user = "xxxx_mysql";

# and what is the password to login to control the database
$database_password = 'xxxxxxx';

# if you change the path to the phpList system, make the change here as well
# path should be relative to the root directory of your webserver (document root)
$pageroot = '/mail';

Doing a Google search for nichost.ru database settings, I note that userid.mysql is the way you access phpMyAdmin, but is that the actual database NAME you are using for the database for phpList?

userid.mysql is default for nichost, and other databases work fine in this domain. Thats what i use for "database_host".

The database NAME i'm giving myself in admin panel, when creating a new database of course. Now it's type of "xxxx_mail"