Problem with default embargo time.

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Problem with default embargo time.

Postby SteveS » 3:06am, Wed 25 Sep, 2013

Just upgraded to version 3.02 from 2.10.19.

With version 2.10.19 if I create a message at server time 21:03 then the embargo time will automatically be set to 21:00.

With version 3.02 if I create a message at server time 21:03 then the embargo time will automatically be set to 22:00.

This means that it may take up to an hour before the message is sent. What do I need to change so the message is immediately sent.

The actual server is on mountain time and my php.ini is set to central time (date.timezone = "America/Chicago") since all of my clients are on central time.

Thanks,
Steve
SteveS
PL Nut
 
Posts: 30
Joined: 10:19pm, Tue 16 Feb, 2010

Re: Problem with default embargo time.

Postby SteveS » 9:25pm, Wed 25 Sep, 2013

I still haven't found a solution to this. Here is what the version 3 documentation states:

Embargoed – A stoppage put on a campaign message so it is not send before a predetermined time and date set by the administrator. It is a capability used when sending campaigns. By default, the embargo is set to today at 0:00, meaning the campaigns are sent immediately after the queue is processed. It is important to note that the embargo has an effect on the time the sending of a message starts, and not the time that the messages actually arrive in a subscriber’s inbox.

As noted in my previous post, the embargo is not being set to 0:00, it is being set to current hour plus 1 hour. I am letting my admins know they need to manually set the embargo time but sometime they forget and then the message is not delivered until someone processes the queue later in the day.
SteveS
PL Nut
 
Posts: 30
Joined: 10:19pm, Tue 16 Feb, 2010

Re: Problem with default embargo time.

Postby duncanc » 10:49am, Thu 26 Sep, 2013

The problem seems to be that phplist uses the php time and the database time interchangeably. In your case the php time is one hour ahead of the database time causing the embargo time to be set incorrectly.

Does removing the ini file setting solve the problem? I'm not sure that changing the php time zone is a good idea as you will then see some times in that time zone and other times in the database time zone, and no indication of which is which.

Also, the documentation is incorrect. The embargo is initially set to the current time. The scheduling tab tries to display the embargo time to the most recent quarter hour but that doesn't seem to work and shows the current hour. When you move away from that tab a new value is saved for the embargo time.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: Problem with default embargo time.

Postby duncanc » 7:18am, Sat 28 Sep, 2013

Just noticed that the config.php file has a define for SYSTEM_TIMEZONE.
# Time Zone
# By default phpList will operate in the Timezone of your server. If you want to work
# in a different Timezone, you can set that here. It will need to be a valid setting for
# both PHP and Mysql. The value should be a city in the world
# to find PHP timezones, check out http://php.net/manual/en/timezones.php
# You will also need to tell Mysql about your timezones, which means you have to load the timezone
# data in the Mysql Database, which you can find out about here:
# http://dev.mysql.com/doc/refman/5.0/en/ ... o-sql.html
# make sure that the value you use works for both PHP and Mysql. If you find strange discrepancies
# in the dates and times used in phpList, you probably used the wrong value.

# define('SYSTEM_TIMEZONE','Europe/London');

phplist then tries to apply that timezone to both mysql and php, so that might resolve your problem.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: Problem with default embargo time.

Postby SteveS » 1:46pm, Sat 28 Sep, 2013

Duncan - Thanks for the suggestion. I had already tried that and get the error:

<div id="dberror">Database error 1298 while doing query Unknown or incorrect time zone: 'America/Chicago'</div>Error setting timezone in Sql Database

Since I'm on a shared server, that mysql function may not be supported. I have also tried other formats for the time zone with the same result.

phpList is a great program and I very much appreciate the work that has gone into it.
SteveS
PL Nut
 
Posts: 30
Joined: 10:19pm, Tue 16 Feb, 2010

Re: Problem with default embargo time.

Postby SteveS » 6:30pm, Sun 29 Sep, 2013

I found a workaround. In the config.php file I added the line:

Code: Select all
date_default_timezone_set('America/Boise');


With this command, only phplist uses Mountain time (same as the shared server). This way all of my other web pages and sites can still use central time. My admins can now skip the scheduling tab when they want the campaign to be sent immediately (which is 99% of the time).
SteveS
PL Nut
 
Posts: 30
Joined: 10:19pm, Tue 16 Feb, 2010

Re: Problem with default embargo time.

Postby StudioJoe » 5:30pm, Wed 02 Oct, 2013

Based on this thread, I set the config.php timezone to the same as the server ('CDT') on my shared account to:

Code: Select all
# Time Zone
# By default phpList will operate in the Timezone of your server. If you want to work
# in a different Timezone, you can set that here. It will need to be a valid setting for
# both PHP and Mysql. The value should be a city in the world
# define('SYSTEM_TIMEZONE','Europe/London');
date_default_timezone_set('America/Chicago');


I live in the Eastern timezone, as does everyone on my maillist. Thanks!
StudioJoe
PL Nut
 
Posts: 19
Joined: 2:24pm, Thu 01 Aug, 2013

Re: Problem with default embargo time.

Postby derfred » 4:02pm, Thu 09 Apr, 2015

I stuck into a problem related to timezones similar to this and this:

The rss had a publish time 1 hour ahead of the phplist time so when I as trying to send the emails phplist could never find any rss item whose publish time was within the previous hour.

It was easy to solve but hard to find, thats why I´m posting this message. LOOK at the "View RSS items" time and make sure it is behind the current server time (phplist time is you haven´t changed it in the config.php file)

To solve this I set my rss source script to post the date I needed (changed the timezone)

This is not a big deal but cost me almost a day to figure out.

Since this is my first post, I could not close it without thanking the developers for this magnificent software. :)
derfred
phpList newbie
 
Posts: 2
Joined: 3:52pm, Thu 09 Apr, 2015

Re: Problem with default embargo time.

Postby duncanc » 7:51pm, Fri 10 Apr, 2015

derfred wrote:
The rss had a publish time 1 hour ahead of the phplist time so when I as trying to send the emails phplist could never find any rss item whose publish time was within the previous hour.


I guess that your php and mysql timezones are not the same. The RSS Feed plugin uses both and they need to be the same. You can set them to be the same using the Timezone plugin (click Find plugins on the Manage plugins page).
Please ask any further questions about the RSS Feed plugin on this topic https://forums.phplist.com/viewtopic.php?f=7&t=42237.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: Problem with default embargo time.

Postby derfred » 10:37pm, Tue 21 Apr, 2015

Thank you for the idea, I´ll try that.
derfred
phpList newbie
 
Posts: 2
Joined: 3:52pm, Thu 09 Apr, 2015


Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 3 guests

cron