google apps, smtp and bounce handling

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

google apps, smtp and bounce handling

Postby shentabla » 3:17am, Mon 28 Oct, 2013

Hi there,

I've got phpList 3.0.5 running on my website (ethnosuperlounge.com), which is hosted by Dreamhost.
My email is hosted via Google apps.
When I set up phpList initially to use phpMailer (as is default), my emails were blocked by most major hosts (Hotmail, Yahoo, etc).
With this initial setup, bounce handling was working fine via the no-reply@ethnosuperlounge.com email address I set up.

Dreamhost recommended I try sending the mails via SMTP to get around the Hotmail block, which worked, but now bounces come back to my "From:" email address instead of the "no-reply" address, so bounce handling isn't working.

I tried having the mail sent through no-reply@...., but then Hotmail perceived the mail as spam.
I'm not really happy about having my usual email password in the config file, so any other suggestions would be welcome.

Here are the relevant settings:
$message_envelope = 'no-reply@ethnosuperlounge.com';
$bounce_protocol = 'pop';
define ("MANUALLY_PROCESS_BOUNCES",1);
$bounce_mailbox_host = 'smtp.gmail.com';
$bounce_mailbox_user = 'no-reply@ethnosuperlounge.com';
$bounce_mailbox_password = '{password}';
$bounce_mailbox_port = "995/pop3/ssl/novalidate-cert";

define("PHPMAILERHOST",'smtp.gmail.com');
$phpmailer_smtpuser = '{usual address}@ethnosuperlounge.com';
$phpmailer_smtppassword = '{password}';
define('PHPMAILERPORT',465);
define("PHPMAILER_SECURE",'ssl');
shentabla
phpList newbie
 
Posts: 2
Joined: 3:00am, Mon 28 Oct, 2013

Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 1 guest