Page 1 of 1

No Statistics what so ever

PostPosted: 11:04pm, Fri 20 Jun, 2014
by surfingcinv
Hello,

Installed and configured PHPLIST, per documention. I sent out a successful newsletter campaign to a list of about 2500 subscrbers. I saw all the traffic and confirmations of lists. Everything looked correct from my google analytics from email campaign to website, but when I look under statistics in PHPLIST, I have absolutely nothing.

No statistics overview
no View opens
campaign click
URL

So I installed the advanced statistics plug in and still get no data.

Date, Sent, Opened, Clicked, Bounced
17 Jun 2014 2495 0.0% (0) 0 0 0 (0)

What am I doing wrong?

Thank you

Alex

Re: No Statistics what so ever

PostPosted: 11:25am, Thu 26 Jun, 2014
by danwaterloo
you might want to make sure that in the config.php file, that the CLICKTRACK line is in there, and set to '1'

Code: Select all
# Click tracking
# If you set this to 1, all links in your emails will be converted to links that
# go via phplist. This will make sure that clicks are tracked. This is experimental and
# all your findings when using this feature should be reported to mantis
# for now it's off by default until we think it works correctly
define('CLICKTRACK',1);

Re: No Statistics what so ever

PostPosted: 5:00pm, Mon 30 Jun, 2014
by surfingcinv
Geez, yeah that flag was off. The tutorial I followed missed this step. Enabled and will test and post my results.

thank you

Re: No Statistics what so ever

PostPosted: 5:43pm, Wed 22 Oct, 2014
by surfingcinv
Hello ,

I really need some help here.I've been following any tips or configurations I can find and I still cannot get campaign statistics to work. Ive gone through the above steps and setup the define('CLICKTRACK',1);

Appreciate it much

Alex

Re: No Statistics what so ever

PostPosted: 10:46pm, Tue 28 Oct, 2014
by surfingcinv
Bumping this... really need some help on this, anyone?

Re: No Statistics what so ever

PostPosted: 11:45am, Wed 29 Oct, 2014
by danwaterloo
Perhaps you can try the following to troubleshoot further....

1. Turn off the Google analytics for now, so that the links generated by phplist come directly back to your phpList installation.

2. Send yourself a test email, and the links will be converted to the 'linktrack' links that measure the response. Click on one of the links... does it work properly? If so, then your settings for phpList are correct. If not, then get that correctly configured. Once it's properly configured, you should at least get a 'view' and a 'click' from your test email. If you get an error when clicking on a link, (i.e. 'page not found'), then you'll need to go to your 'Config', 'Settings' and double check the 'General' settings for the domain name and website are correct. These are used to generate the url of the clicktrack links...

Re: No Statistics what so ever

PostPosted: 7:25pm, Wed 29 Oct, 2014
by surfingcinv
1. "Always add Google tracking code to campaigns"
Changed this from Yes to "No"

2. Setup a new campaign with 2 test emails, just made a simple text line with a URL link to a website in the body.


Send campaign and checked emails, everything looks correct but

When I go back to the message statistics for opens , there is nothing displayed.

Im having a hard time understanding how to follow your troublshooting in step 2. Could you explain in more detail?

And thanks...

Re: No Statistics what so ever

PostPosted: 3:57pm, Fri 31 Oct, 2014
by surfingcinv
if someone can help me resolve tracking, I will donation some cash to their paypal account.

Re: No Statistics what so ever

PostPosted: 4:45pm, Fri 31 Oct, 2014
by danwaterloo
It's more than likely in your server... you didn't mention what version of phpList your using, or what o/s, and what version of php you have.

If you want to send me a private message, I can let you know what I need to login, etc.

Re: No Statistics what so ever

PostPosted: 8:29am, Sun 02 Nov, 2014
by alexeiz
Absolutely the same problem.

Version 3.010, I would like to have at least open statistics.
Sent a test message (with [USERTRACK] ) to a dozen of my own addresses, received the emails, opened them. Looked at the statistics - opened = 0.

It used to work in the older version. I've checked config.php, read what I could get on the issue, went through over about 100 posts and replies. I also had statistics plugin installed, but I doesnt make any difference.

Re: No Statistics what so ever

PostPosted: 5:47pm, Mon 03 Nov, 2014
by surfingcinv
danwaterloo,

Sorry about the missing info:

Version: 3.0.6
Its installed through a hosted inmotion server

I will send ya a PM, and will post a fix eventually - however we find a fix.

Sending PM

Re: No Statistics what so ever

PostPosted: 6:36pm, Mon 03 Nov, 2014
by surfingcinv
Dan , did you get my PM?

thanks

Re: No Statistics what so ever

PostPosted: 7:31pm, Mon 22 Dec, 2014
by SteveK
I'm having the same problem also. I'm using HostGator.com as my host. I just upgraded from version 3.0.6 to 3.0.10 because I thought that may have played a role in this, but after the upgrade I have the same results. I'm sending to 3 subscribers (3 of my own email addresses) as a test, then opening them, and the statistics are showing 3 sent, 0 bounces, 0 forwards, 0 views. I also find that not all the subscribers are receiving my mailings, it's reporting 3 sent but I'm only receiving 1 or 2 of them.

I tried setting CLICKTRACK to '1', but then the links in my campaign don't work. Instead of going to the link, I get a page not found error.

I'm using the following Plugins: Campaigns Plugin version2014-05-28, Captcha Plugin version 2014-10-26, Common Plugin version 2014-10-22, NameFCKeditor plugin for phpList
version 0.1.

I would like to get PHPlists working but in the meantime will keep on using Constant Contact.