Error sending message after sending 9 messages [SOLVED]

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Error sending message after sending 9 messages [SOLVED]

Postby enivid » 1:10pm, Tue 02 Sep, 2014

I have tried to send a campaign today and encountered a strange problem. It was my first time after upgrading version 3.0.6. Previously I have sent a lot of campaigns with version 2.10.19 without any problems.

When PHPList began to process the queue, it has sent to first 9 addresses successfully, then it proceeded to output "Error sending message" for everyone else (1724 emails). Stopping and resuming the process does not help. It outputs "Error sending message" for every remaining email and does so very quickly.

What could be the reason for such behavior?
enivid
phpLister
 
Posts: 6
Joined: 5:21pm, Wed 13 Aug, 2014

Re: Error sending message after sending 9 messages

Postby enivid » 5:14pm, Tue 02 Sep, 2014

I guess I know what is happening, but I do not know why it is happening and how to fix it.

It looks like sendmail is blocking phpList from sending new messages for about 30 minutes after receiving 10 messages from it. That is strange, considering that phpList is sending them from localhost and cannot be considered a spammer... Any ideas how to fix it?
enivid
phpLister
 
Posts: 6
Joined: 5:21pm, Wed 13 Aug, 2014

Re: Error sending message after sending 9 messages

Postby Dragonrider » 5:42pm, Tue 02 Sep, 2014

What are your send rates (in config.php file) around lines 340-350?

Also, what are the limits on email sending imposed by your host?
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Error sending message after sending 9 messages

Postby enivid » 5:47am, Wed 03 Sep, 2014

The issue was fixed by changing PHPMAILERHOST from external IP address to localhost.
enivid
phpLister
 
Posts: 6
Joined: 5:21pm, Wed 13 Aug, 2014


Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 1 guest

cron