SMTP HELO Problem

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

SMTP HELO Problem

Postby bnosie » 2:52pm, Wed 10 Sep, 2014

phpList version 3.0.7, using Firefox 31 and Chrome 35.

On an internal network, I can't get SMTP to work. I have the smtp server specified in the config.php. This server also hosts 4 other websites, and all use this same smtp server for email, so I know it works. When I send a test email, I get the message that it failed. In the event log, I get the following:

10 2014-09-10 09:37:41 Error sending email to me@test.com The following From address failed: me@test.com : MAIL not accepted from server,503,5.0.0 Polite people say HELO first SMTP server error: 5.0.0 Polite people say HELO first SMTP server error: 5.0.0 Polite people say HELO first

This smtp server does not use authentication, so the user and password are not set. Any ideas?
bnosie
phpList newbie
 
Posts: 3
Joined: 2:41pm, Wed 10 Sep, 2014

Re: SMTP HELO Problem

Postby duncanc » 3:36pm, Wed 10 Sep, 2014

The SMTP HELO command seems to be using me@test.com email address and that is being rejected by the mail server. You probably need to use an email address on a domain that the mail server recognises.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: SMTP HELO Problem

Postby bnosie » 3:57pm, Wed 10 Sep, 2014

me@test.com is not the actual email address, the actual address used is recognized by the smtp server. it is in fact in the same domain as the smtp server. I am able to send emails to that address from the other websites on the same server hosting phpList. It doesn't matter what email address I use, it still fails with the same errors.
bnosie
phpList newbie
 
Posts: 3
Joined: 2:41pm, Wed 10 Sep, 2014

Re: SMTP HELO Problem

Postby duncanc » 4:16pm, Wed 10 Sep, 2014

This is not to do with the address that you are sending to, but that with which phplist identifies itself to the SMTP server.
The following From address failed: me@test.com : MAIL not accepted from server

If you have configured bounce processing then the $message_envelope value is used. Otherwise I think that it is the From address when you compose a campaign. So whichever value is being used is not acceptable to the SMTP server.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: SMTP HELO Problem

Postby bnosie » 4:38pm, Wed 10 Sep, 2014

Thanks for your reply. I'm starting to understand better. I've changed the sender to sender@test.com and the recipient to recipient@test.com, to try to avoid confusing them. I still get

19 2014-09-10 12:24:27 Error sending email to recipient@test.com The following From address failed: sender@test.com : MAIL not accepted from server,503,5.0.0 Polite people say HELO first SMTP server error: 5.0.0 Polite people say HELO first SMTP server error: 5.0.0 Polite people say HELO first

It seems that changing the From: address within the campaign has no effect on the sender within the error. Only by changing it in Settings -> Person in charge of this system, will the sender address be changed within the error message.

I've tried multiple sender addresses here, including addresses used successfully elsewhere on this web server, to no avail.

I do not have bounce processing configured.

I appreciate your help.
bnosie
phpList newbie
 
Posts: 3
Joined: 2:41pm, Wed 10 Sep, 2014

Re: SMTP HELO Problem

Postby duncanc » 5:26pm, Wed 10 Sep, 2014

I think that you will need to raise this problem with whoever runs the SMTP server. Explain which email address you are using and ask why that is being rejected.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: SMTP HELO Problem

Postby Rietvink » 4:07pm, Thu 08 Jan, 2015

I've got exactly the same problem. While all worked fine last June when we send our last mailing, I can't send any mail at the moment.

The error is in Dutch but it is the same:
Fout bij het verzenden van het e-mail bericht aan xxxxxx@gmail.com The following From address failed: xxxxx@xxxxxx.nl : MAIL FROM command failed,503,polite people say HELO first

Any solution yet?
Rietvink
phpList newbie
 
Posts: 1
Joined: 4:02pm, Thu 08 Jan, 2015

Re: SMTP HELO Problem

Postby Dragonrider » 10:19pm, Thu 08 Jan, 2015

Rietvink wrote:I've got exactly the same problem. While all worked fine last June when we send our last mailing, I can't send any mail at the moment.

The error is in Dutch but it is the same:
Fout bij het verzenden van het e-mail bericht aan xxxxxx@gmail.com The following From address failed: xxxxx@xxxxxx.nl : MAIL FROM command failed,503,polite people say HELO first

Any solution yet?


This issue seems to arise when you use different email addresses to send from in your configuration page.

This site has a number of suggestions to fix this non-phpList specific issue though I would try this one first.
Sender matching – make sure you’re sending from the same email address that the recipient sees your email coming in as (ie. don’t make the “from” field differ from the email address used in your outgoing mail settings).
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom


Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 3 guests