Page 1 of 1

Command Line cannot open mailbox

PostPosted: 12:56pm, Wed 15 Oct, 2014
by s1mpleman
Hello everyone, hope you are well!

New user to PHPList, and what some might call a linux novice I suppose. First of all, thank you for this awesome software! Absolutely loving it.

I've set up command line to automatically process bounces and the queue, it's processing the queue fine but I keep getting an error can't open mailbox file, can't open mailbox Bounces/s1mpleman: no such mailbox.

I have the mailbox setup as a symlink from /var/mail/s1mpleman to the home directory of www-data user which is /var/www/html/

the Bounces folder is contained within /var/www/html.

PHPlists reads it fine, I can check the bounces and read them through the web interface but whenever I run /usr/bin/php -q /var/www/html/lists/admin/index.php -p processbounces -c /var/www/html/lists/config/config.php I get the following error.

It's a blumming strange one but I'm guessing it has something to do with my permissions.

Which are:
/var/www/html/Bounces/s1mpleman
lrwxrwxrwx 1 s1mpleman www-data 19 Oct 13 11:51 s1mpleman -> /var/mail/s1mpleman
and
/var/mail/s1mpleman
-rwxrwxrwx 1 s1mpleman www-data 560 Oct 14 17:58 s1mpleman

I'm running

phpList version 3.0.8 (c) 2000-2014 phpList Ltd, http://www.phplist.com
Server version: Apache/2.4.7 (Ubuntu)
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies


Any help would be greatly appreciated from anyone who has this setup and running because it's confusing me. I've tried messing with putting the full location into config.php but it left me with the same results. The web interface could see bounces but command line could not.

Confused.com!

Thanks for reading