Problem after upgrade from 3.06 to 3.09

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Problem after upgrade from 3.06 to 3.09

Postby Feckless » 5:49am, Tue 21 Oct, 2014

I have been practicing with PHPLIST on a (shared) production server running Apache 2.2.26; MySQL 5.5.38-35.2; and, PHP 5.4.32.

My client machine is a Windows 7 Professional, running Firefox 32.0.3.

I was not having any problems with 3.06. I was constantly prompted to update, so I finally succumbed and upgraded. I followed the standard directions for updating; i.e,

1. Backed up the database;
2. Copied the config.php file to a different place;
3. Overwrote the "lists" folder with the new "lists" folder;
4. Put the old config.php file back in place.
5. Logged in with no trouble, and hit the "upgrade" link, which ran fine.

I then "verified" the database structure, with no problems. I was able to access and see all my lists, etc. No problems.

Only problem is that when I try to send a "test" email using my "test" list, I get this message:

"Sent test mail to: mytestaccount@domain.com failed"

That's it! I deleted and rebuilt my test email address with the same result.

In the config.php, I set to "0" --> define ("TEST",0), so I'm stumped. Any suggestions will be greatly appreciated.

Thanks.
Feckless
phpLister
 
Posts: 10
Joined: 4:48pm, Thu 10 Apr, 2014

Re: Problem after upgrade from 3.06 to 3.09

Postby XaviBest » 1:10pm, Tue 21 Oct, 2014

Can you tell us what the log events says?
XaviBest
phpList newbie
 
Posts: 2
Joined: 12:52pm, Tue 21 Oct, 2014

Re: Problem after upgrade from 3.06 to 3.09

Postby Feckless » 5:14pm, Tue 21 Oct, 2014

I'm trying to get access to the log files. I'm assuming you mean PHP error log? When I get the info, I'll post.

Thanks
Feckless
phpLister
 
Posts: 10
Joined: 4:48pm, Thu 10 Apr, 2014

Re: Problem after upgrade from 3.06 to 3.09

Postby Dragonrider » 8:27pm, Tue 21 Oct, 2014

Feckless wrote:I'm trying to get access to the log files. I'm assuming you mean PHP error log? When I get the info, I'll post.

Thanks

I think actually XaviBest may be referring to the phpList event log.

However, there is an issue that has been discovered with 3.0.9 and a fix has been issued by the release of version 3.0.10 (link in my siggy).

"Sent test mail to: mytestaccount@domain.com failed"

No, this could be related to the 3.0.9 issue but that message comes up in 3.0.x if the account you are trying to send to is not an active subscriber. Did you get an option to ADD the email as a new subscriber?
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Problem after upgrade from 3.06 to 3.09

Postby XaviBest » 10:51am, Wed 22 Oct, 2014

Yes, I'm refering to the PHPList event Log.

If you see something like the attached image "SMTP connect() failed.", try to change the following code on class.phplistmailer.php

Code: Select all
require_once dirname(__FILE__).'/accesscheck.php';

if (defined('PHPMAILER_PATH') and PHPMAILER_PATH != '') {
    #require_once '/usr/share/php/libphp-phpmailer/class.phpmailer.php'
    require_once PHPMAILER_PATH;
} else {
    //https://github.com/PHPMailer/PHPMailer
    //require_once dirname(__FILE__) . '/PHPMailer/PHPMailerAutoload.php';
   require_once dirname(__FILE__) . '/PHPMailer-5.2.5/class.phpmailer.php';
}


Restoring the old PHPMailer class has solved the issue. Check that your instalation has the folder PHPMailer-5.2.5.

I think it could be a bug on this release.
Attachments
Captura.PNG
Captura.PNG (31.53 KiB) Viewed 3001 times
XaviBest
phpList newbie
 
Posts: 2
Joined: 12:52pm, Tue 21 Oct, 2014

Re: Problem after upgrade from 3.06 to 3.09

Postby Feckless » 5:28pm, Wed 29 Oct, 2014

Sorry for slow reply, but I was off the line.
I asked my ISP for access to the PHP error log, but found no logged errors in there.

I then spotted an update to version 3.0.10, which seems to have fixed my test mail problem, but I still can't export lists to a CSV file.

When I hit the "EXPORT" button, I get a progress wheel, then the screen refreshes with this message:

Image

I never get the chance to download anything.

I am using the new config.php file that comes with version 3.0.10 which I update with all my specific credentials. Still puzzled.
Last edited by Feckless on 3:35pm, Fri 31 Oct, 2014, edited 2 times in total.
Feckless
phpLister
 
Posts: 10
Joined: 4:48pm, Thu 10 Apr, 2014

Re: Problem after upgrade from 3.06 to 3.09

Postby Feckless » 10:34pm, Wed 29 Oct, 2014

From a post by XaviBest:

Restoring the old PHPMailer class has solved the issue. Check that your instalation has the folder PHPMailer-5.2.5.


Version 3.0.10 does not have PHPMailer-5.2.5 folder. It' just named PHPMailer. I tried renaming the folder to PHPMailer-5.2.5, but then the whole application fails. It just doesn't load. No error message, just a white screen.

I have the install packages for 3.0.5, 3.0.6, 3.0.9 and 3.0.10. My last functioning version was 3.0.6.

There are 24 php files and 1 .htaccess file in \lists\admin\actions in version 3.0.6. There is no file named export.php, but exporting worked find.

version 3.0.10 has 28 php files and 1 .htaccess files in \lists\admin\actions. There is a file named export.php. However, exporting does not work.

It appears that the whole setup has changed a lot between 3.0.6 and 3.0.10. It does not seem that many users are having this problem, so I'm starting to think that I'm having some kind of permission or setup problem. My ISP techs are saying "NO" to that. They argue that there is something awry inside PHPList, so I'm a bit stymied.

I'm going to blow everything off and reinstall. I'll post the results one way or the other.
Feckless
phpLister
 
Posts: 10
Joined: 4:48pm, Thu 10 Apr, 2014

Re: Problem after upgrade from 3.06 to 3.09

Postby Feckless » 3:39pm, Fri 31 Oct, 2014

So, I completely uninstalled and reinstalled everything (version 3.0.10) but still can't export. The "test mail" functionality is working again.

After trying to export, NOTHING appears in the phplist event log, so I'm a bit lost at sea here.

Here is the screenshot again of what happens after trying to export users:

Image

The mysterious text
id Email Is this subscriber confirmed Is this subscriber blacklisted Did this subscriber manually confirm Number of bounces


Appears the
All done message


Anybody know where that comes from? Could be a clue.
Feckless
phpLister
 
Posts: 10
Joined: 4:48pm, Thu 10 Apr, 2014


Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 3 guests

cron