[SOLVED] Page Not Found

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

[SOLVED] Page Not Found

Postby okppsa » 6:09am, Wed 12 Nov, 2014

Quite a few places while clicking around the Admin panel of phplist, I run into a Page not found error.

Specifically, I am adding details to list subscriber, I fill in the details of the attributes I have set and then click Save changers, it takes me to

www.okppsa.org/lists/admin/?page=user&id=2

however the page is a wordpress 404 page. :?: (I am using wordpress on the front end for my site visitors.

It seems if I click the back button on the browser, then click Reload on the browser the data I entered shows up. If I navigate back to the same place again, the data appears to have saved.

What am I doing wrong? Any suggestions to correct this?

Powered by phplist, version 3.0.10
Chrome Version 38.0.2125.111 m
okppsa
phpList newbie
 
Posts: 2
Joined: 5:56am, Wed 12 Nov, 2014

Re: Page Not Found

Postby Dragonrider » 9:19am, Wed 12 Nov, 2014

Have you set $pageroot to the path you are using in config/config.php?
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Page Not Found

Postby okppsa » 4:50am, Fri 14 Nov, 2014

Thank you sir!

It would appeared to have fixed the issue. I placed my PHPList into list directory instead of lists directory.

I took from config/config_extended.php

# if you change the path to the phpList system, make the change here as well
# path should be relative to the root directory of your webserver (document root)
$pageroot = '/lists';

changed the $pageroot and placed it into config/config.php everything seems to be working!
okppsa
phpList newbie
 
Posts: 2
Joined: 5:56am, Wed 12 Nov, 2014


Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 4 guests