message to request your confirmation failed

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

message to request your confirmation failed

Postby ELMIT » 8:57am, Mon 05 Jan, 2015

I have installed 3.0.10 and got some troubles:

1. If I use the subscribe page, it leads me to a page:
Sorry, sending the message to request your confirmation failed, please click "Reload" to try again. If it still does not work, please contact the administrator.


(Saddly, I am the administrator, and I have no idea what to do)

2. I use my isp's smtp server, which works fine, when I use smartserialmail with the mail settings there:
stmp server: msa.myisp.net
server port 587 OR 25
Security: None

My PHPlist config file is attached.

When I send out with PHPlist I get errors:
Error sending email to xxx@gmail.com The following From address failed: noreply@mydomain.com : Called MAIL FROM without being connected

How can I track down these two problems?
ELMIT
PL Geek
 
Posts: 66
Joined: 7:33am, Fri 15 Jan, 2010
Location: Taipei, Taiwan

Re: message to request your confirmation failed

Postby Dragonrider » 9:43am, Mon 05 Jan, 2015

According to the first result of over 4 million on Google, if you are using port 587 then your security should be TLS, not None. Give that a try?
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: message to request your confirmation failed

Postby ELMIT » 10:40am, Mon 05 Jan, 2015

I tried:
define("PHPMAILERHOST",'msa.myisp.net:587');
define("PHPMAILER_SECURE",'ssl');

(emails I use here had to be edited to with a blank before and after @)

phpList version 3.0.10 (c) 2000-2015 phpList Ltd, http://www.phplist.com
phpList - Recently sent : 98
phpList - Started [0.0555070000] (86)
phpList - Sending in batches of 4000 messages [0.0001540000] (87)
phpList - This batch will be 3902 emails, because in the last 3600 seconds 98 emails were sent [0.0001040000] (88)
phpList - Processing has started, [0.0004390000] (91)
phpList - One campaign to process. [0.0560520000] (96)
phpList - Processing message 7 [0.0692870000] (111)
phpList - Looking for subscribers [0.0817320000] (116)
phpList - Found them: 4 to process [0.0416410000] (122)
phpList - Processing batch of: 4 [0.0831240000] (126)
phpList - Error sending message 7 (1/3902) to r123 @ mysite.com (r123 @ mysite.com) [5.4298150000] (161)
phpList - Error sending message 7 (2/3902) to r456 @ mysite.com (r456 @ mysite.com) [5.7695240000] (187)
phpList - Error sending message 7 (3/3902) to dr456 @ mysite.com (dr456 @ mysite.com) [5.5119710000] (210)
phpList - Error sending message 7 (4/3902) to r789 @ example.com (r789 @ example.com) [5.6873210000] (231)
phpList - Processed 4 out of 4 subscribers [0.2674560000] (238)
phpList - Script stage: 5 [0.0501130000] (240)
phpList - 4 failed (will retry later) [0.0001380000] (241)
phpList - 1 campaign
phpList - 0 num_users_for_message
phpList - 4 batch_count
phpList - 3902 batch_total
phpList - 4 sendemail returned false total
phpList - 0 send blocked by domain throttle
phpList - 0 add attachment error
phpList - 4 sendemail returned false
phpList - 4 total_users_for_message 7
phpList - 4 processed_users_for_message 7
phpList - Finished this run [0.2338500000] (278)



define("PHPMAILERHOST",'msa.myisp.net:587');
#define("PHPMAILER_SECURE",'tls');
phpList version 3.0.10 (c) 2000-2015 phpList Ltd, http://www.phplist.com
phpList - Recently sent : 84
phpList - Started [0.1402030000] (86)
phpList - Sending in batches of 4000 messages [0.0001750000] (87)
phpList - This batch will be 3916 emails, because in the last 3600 seconds 84 emails were sent [0.0001620000] (88)
phpList - Processing has started, [0.0003780000] (91)
phpList - One campaign to process. [0.0899640000] (96)
phpList - Processing message 7 [5.2951570000] (127)
phpList - Looking for subscribers [0.2087100000] (132)
phpList - Found them: 4 to process [0.0505510000] (138)
phpList - Processing batch of: 4 [0.1081420000] (142)
phpList - Error sending message 7 (1/3916) to r123 @ mysite.com (r123 @ mysite.com) [10.5543920000] (175)
phpList - Error sending message 7 (2/3916) to r456 @ mysite.com (r456 @ mysite.com) [10.6961450000] (201)
phpList - Error sending message 7 (3/3916) to dr456 @ mysite.com (dr456 @ mysite.com) [5.8288640000] (224)
phpList - Error sending message 7 (4/3916) to r789 @ example.com (r789 @ example.com) [5.5943790000] (245)
phpList - Processed 4 out of 4 subscribers [0.3506110000] (252)
phpList - Script stage: 5 [0.0501130000] (254)
phpList - 4 failed (will retry later) [0.0001650000] (255)
phpList - 1 campaign
phpList - 0 num_users_for_message
phpList - 4 batch_count
phpList - 3916 batch_total
phpList - 4 sendemail returned false total
phpList - 0 send blocked by domain throttle
phpList - 0 add attachment error
phpList - 4 sendemail returned false
phpList - 4 total_users_for_message 7
phpList - 4 processed_users_for_message 7
phpList - Finished this run [0.2835750000] (292)



define("PHPMAILERHOST",'msa.myisp.net:25');
#define("PHPMAILER_SECURE",'tls');
phpList version 3.0.10 (c) 2000-2015 phpList Ltd, http://www.phplist.com
phpList - Recently sent : 81
phpList - Started [0.0334270000] (86)
phpList - Sending in batches of 4000 messages [0.0001260000] (87)
phpList - This batch will be 3919 emails, because in the last 3600 seconds 81 emails were sent [0.0000900000] (88)
phpList - Processing has started, [0.0003470000] (91)
phpList - One campaign to process. [0.0484730000] (96)
phpList - Processing message 7 [0.0600820000] (111)
phpList - Looking for subscribers [0.0986210000] (116)
phpList - Found them: 4 to process [0.0588670000] (122)
phpList - Processing batch of: 4 [0.1001290000] (126)
phpList - Error sending message 7 (1/3919) to r123 @ mysite.com (r123 @ mysite.com) [5.4516100000] (161)
phpList - Error sending message 7 (2/3919) to r456 @ mysite.com (r456 @ mysite.com) [5.6789380000] (187)
phpList - Error sending message 7 (3/3919) to dr456 @ mysite.com (dr456 @ mysite.com) [5.5686830000] (210)
phpList - Error sending message 7 (4/3919) to r789 @ example.com (r789 @ example.com) [10.7648900000] (231)
phpList - Processed 4 out of 4 subscribers [0.5927720000] (238)
phpList - Script stage: 5 [0.1085590000] (240)
phpList - 4 failed (will retry later) [0.0001670000] (241)
phpList - 1 campaign
phpList - 0 num_users_for_message
phpList - 4 batch_count
phpList - 3919 batch_total
phpList - 4 sendemail returned false total
phpList - 0 send blocked by domain throttle
phpList - 0 add attachment error
phpList - 4 sendemail returned false
phpList - 4 total_users_for_message 7
phpList - 4 processed_users_for_message 7
phpList - Finished this run [0.3337870000] (278)
ELMIT
PL Geek
 
Posts: 66
Joined: 7:33am, Fri 15 Jan, 2010
Location: Taipei, Taiwan

Re: message to request your confirmation failed

Postby ELMIT » 2:38am, Tue 06 Jan, 2015

based on above, what can I do to figure out how to fix it?
ELMIT
PL Geek
 
Posts: 66
Joined: 7:33am, Fri 15 Jan, 2010
Location: Taipei, Taiwan

Re: message to request your confirmation failed

Postby Dragonrider » 9:45am, Tue 06 Jan, 2015

Your first example you are using port 587 and SSL (SSL would use 465). Check your SMTP settings for your email program that you are using to send your messages.

Second and third examples do use TLS but you have commented both
Code: Select all
#define("PHPMAILER_SECURE",'TLS');
in these examples out. (Remove the hash '#' to use this line).

Port 25 should use none for the secure definition.
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom


Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 2 guests