Problem in administration area

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Problem in administration area

Postby cicciods » 9:31pm, Sat 28 Mar, 2015

In administration area in my local installation, after that I go in add user page in this link
http://localhost/phplist/public_html/lists/admin/?page=user&tk=7c14399 the system add user but I'm redirected to this page which doesn't exist http://localhost/lists/admin/?page=user&id=4.
Probably there is a problem of path in my setting.
How can I do?
cicciods
phpList newbie
 
Posts: 3
Joined: 9:24pm, Sat 28 Mar, 2015

Re: Problem in administration area

Postby duncanc » 6:57am, Sun 29 Mar, 2015

You have not installed phplist correctly and appear to have copied the complete zip file instead of the "lists" folder. See the installation notes http://docs.phplist.com/PhplistInstallation.html.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: Problem in administration area

Postby cicciods » 4:25am, Mon 30 Mar, 2015

I would like to install phplist in a different folder.
cicciods
phpList newbie
 
Posts: 3
Joined: 9:24pm, Sat 28 Mar, 2015

Re: Problem in administration area

Postby duncanc » 2:05pm, Mon 30 Mar, 2015

Copy the "lists" folder and then rename it.
You also need to modify this line in config.php file to reflect the new folder name
Code: Select all
$pageroot = '/lists';
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: Problem in administration area

Postby Dragonrider » 2:40pm, Mon 30 Mar, 2015

duncanc wrote:Copy the "lists" folder and then rename it.
You also need to modify this line in config.php file to reflect the new folder name
Code: Select all
$pageroot = '/lists';

It's probably already set to that which is the cause of the invalid links, or not set at all as phpList 3 defaults to $pageroot = "/lists"; if it's not there in the first place.
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom


Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 2 guests

cron